Ask Your Question
0

mitaka nova error too many connection mysql

asked 2016-12-03 11:35:20 -0500

vuhiep gravatar image

I installed mitaka but somtime i got the error:

(errno, errorvalue)\n', u"OperationalError: (pymysql.err.OperationalError) (1040, u'Too many connections')\n"]. 2016-12-03 11:44:02.318 22234 ERROR nova.servicegroup.drivers.db

And then I must restart all service Mysql config:

[mysqld] bind-address = 192.168.77.2 default-storage-engine = innodb innodb_file_per_table max_connections = 4096 collation-server = utf8_general_ci character-set-server = utf8

May I miss some config? please teach me. Thanks

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2016-12-05 00:35:07 -0500

kiseok7 gravatar image

You could set "max_connections" on my.cnf configure file. like this:

[mysqld]
...
max_connections = 4096
...
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-12-03 11:35:20 -0500

Seen: 1,586 times

Last updated: Dec 03 '16