keystone-manage: error: argument command: invalid choice: 'fernet_setup'

asked 2016-12-03 07:32:10 -0500

sameh gravatar image

updated 2016-12-06 14:46:52 -0500

rbowen gravatar image

After installing keystone and configure with command: "keystone-manage fernet_setup --keystone-user keystone --keystone-group keystone"

error: argument command: invalid choice: 'fernet_setup'

The same problem with "keystone-manage credential_setup" and "keystone-manage bootstrap"

edit retag flag offensive close merge delete

Comments

Which version of keystone did you install? Run keystone-manage --version.

Bernd Bausch gravatar imageBernd Bausch ( 2016-12-03 17:23:18 -0500 )edit

keystone-manage --version 2014.1.3

sameh gravatar imagesameh ( 2016-12-04 14:47:13 -0500 )edit

afaik this was before the support of Fernet (introduced at Kilo?) and definitely before the support of bootstrap (Mitaka). Your Keystone is too old for these commands.

Bernd Bausch gravatar imageBernd Bausch ( 2016-12-04 16:58:09 -0500 )edit

What can i do to solve this issue? I have already just run "apt install keystone" without any version, Is it any way to install the latest version of keystone? Thanks

sameh gravatar imagesameh ( 2016-12-05 05:43:11 -0500 )edit

It sounds like you have not installed a currently supported release of OpenStack. How did you do the install? What guide are you following?

vern gravatar imagevern ( 2016-12-05 16:38:57 -0500 )edit