Ask Your Question
0

Mitaka nova-manage api_db sync 'error: No sql_connection parameter is established'

asked 2016-12-01 21:02:12 -0600

RedCricket gravatar image

I am trying to set up a Mitaka OpenStack cloud. But when I try to execute:

# /usr/bin/nova-manage --debug api_db sync

And the I get the error message:

error: No sql_connection parameter is established

Yet I am able to access the nova database via mysql command line, using the values I am using for my I have in the /etc/nova/nova.conf:

[database]
connection=mysql://nova:nova@svl-os:3306/nova
edit retag flag offensive close merge delete

Comments

Did you configure nova.conf as per instructions in the link ? http://docs.openstack.org/mitaka/inst...

teju gravatar imageteju ( 2016-12-02 00:25:17 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
1

answered 2016-12-02 04:26:45 -0600

Your nova.conf probably lacks the nova_api setup. From the link provided by teju:

[api_database]
...
connection = mysql+pymysql://nova:NOVA_DBPASS@controller/nova_api
edit flag offensive delete link more

Comments

Looks like nova_api is a new DB schema. I deployed Liberty via the OpenStack community's Puppet modules. I wanted to see what would happen if I simply upgraded the OpenStack community Puppet modules to the Mitaka version and see what happens. I was hoping everything would work just fine :) LOL!

RedCricket gravatar imageRedCricket ( 2016-12-02 12:11:19 -0600 )edit

It was introduced in Mitaka to support Cells v2. Its purpose is to keep cell-global DB content, whereas the old db only contains cell-specific data.

Bernd Bausch gravatar imageBernd Bausch ( 2016-12-02 16:51:59 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-12-01 21:02:12 -0600

Seen: 2,684 times

Last updated: Dec 02 '16