Ask Your Question
4

Neutron net-create requires that tenant_id is specified

asked 2014-01-06 04:08:29 -0500

RBK gravatar image

updated 2014-01-06 13:44:22 -0500

smaffulli gravatar image

I am setting up OpenStack using Neutron networking services, and I am following the setup guides to define three nodes, one is controller, one is network and one is compute.

WHen I try to run below command in network node, I got below error.

[root@network01]# neutron net-create ext-net -- --router:external=True --provider:network_type gre --provider:segmentation_id 2
Running without keystone AuthN requires  that tenant_id is specified

I have checked the /etc/neutron/neutron.conf, and the auth_strategy is set to keystone.

I also check the agent-list, it shown below.

[root@network01 neutron]# neutron agent-list
+--------------------------------------+--------------------+-----------+-------+----------------+
| id                                   | agent_type         | host      | alive | admin_state_up |
+--------------------------------------+--------------------+-----------+-------+----------------+
| 78bd8b96-00c1-4705-a311-d9e6d1c8523e | DHCP agent         | network01 | :-)   | True           |
| f14ffd1c-8a77-46d9-b5cb-78f1acf74215 | L3 agent           | network01 | :-)   | True           |
| fdf0eee1-6bfe-42c9-a307-86061bc134a5 | Open vSwitch agent | network01 | :-)   | True           |

Any idea?

edit retag flag offensive close merge delete

Comments

where is your keystone located ? Did you make the right configuration in neutron.conf to point the right IP/host name of the keystone system ? Can you share your neutron.conf ?

dheeru gravatar imagedheeru ( 2014-01-06 05:51:11 -0500 )edit

3 answers

Sort by ยป oldest newest most voted
3

answered 2014-10-16 10:43:31 -0500

Senol Erdogan gravatar image

command needs admin tenant-id

firstly, take tenant list

 *# keystone tenant-list*

command will return tenants list as you know. such as;

| id | name | enabled | +-----------------------------------------------+----------+-----------+ | 6df22af2a590453ba8488dad5204b138 | admin | True | | a7fef4f8426d49b6b79ff007eb0117a8 | demo | True | | c976cd00104b40e59b7dd7d360aba6e4 | service | True ...

then, get admin tenant-id from list and use in the "neutron net-create" command, like

 *#neutron net-create ext-net --shared --router:external=True --tenant-id 6df22af2a590453ba8488dad5204b138*
edit flag offensive delete link more
0

answered 2014-01-31 23:44:25 -0500

Chris gravatar image

Have you tried using the --tenant-id option?

edit flag offensive delete link more
0

answered 2014-01-06 18:53:48 -0500

RBK gravatar image

Hi

The keystone should be located in the controller (controller02)

[root@controller02 neutron]# keystone service-list +----------------------------------+----------+----------+------------------------------+ | id | name | type | description | +----------------------------------+----------+----------+------------------------------+ | 8ba82ea506d9449a8b9b0879a54f4c8d | glance | image | Glance Image Service | | 93de89ad95e0481ea63a24761bf7c33f | keystone | identity | Keystone Identity Service | | c5cf414ecdeb4512bff84f1053705fd6 | neutron | network | OpenStack Networking Service | | 4b44e29cf9ae4f37ac1f6ea0356e019f | nova | compute | Nova Compute service | +----------------------------------+----------+----------+------------------------------+

below is the neutron.conf located in network node.

[DEFAULT]

core_plugin = neutron.plugins.openvswitch.ovs_neutron_plugin.OVSNeutronPluginV2

api_paste_config = /etc/neutron/api-paste.ini

rpc_backend=neutron.openstack.common.rpc.impl_qpid

[quotas]

[agent] root_helper = sudo neutron-rootwrap /etc/neutron/rootwrap.conf

[keystone_authtoken] auth_host = controller02 admin_tenant_name = service admin_user = neutron admin_password = abc123 auth_url = http://controller02:35357/v2.0 auth_strategy = keystone rpc_backend = neutron.openstack.common.rpc.impl_qpid qpid_hostname = controller02

[database] connection = mysql://neutron:abc123@controller02/neutron

[service_providers]

edit flag offensive delete link more

Comments

keystone can be located/installed any system as opestack use distributed architecture. You need to configure correct hostname or IP address of keystone in appropriate configuration files. Hope your issue is resolved now.

dheeru gravatar imagedheeru ( 2014-01-06 20:35:58 -0500 )edit

I cannot figure out where is the problem, can give some hints?

RBK gravatar imageRBK ( 2014-01-06 20:59:27 -0500 )edit

I have recreated three new nodes again, and this error is no longer occurred, but I have a new error. I will post in a new thread

RBK gravatar imageRBK ( 2014-01-07 02:19:32 -0500 )edit

ok. what is the error ?

dheeru gravatar imagedheeru ( 2014-01-07 04:42:35 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2014-01-06 04:08:29 -0500

Seen: 2,147 times

Last updated: Jan 31 '14