Ask Your Question
0

Cannot SSH Instance on Ubuntu 12.04 LTS

asked 2014-01-06 04:06:54 -0500

jaysonp gravatar image

updated 2014-01-06 13:39:16 -0500

smaffulli gravatar image

Hi all,

I am currently exploring Openstack. I've created an Ubuntu 12.04 LTS image using Virtual Machine Manager. I created it using the default options of the Virtual Machine Manager. I stepped on to the installation of the VM and just provided a very simple username and password credentials. The image was successfully created and stored under /var/lib/libvirt/images. After that, I've uploaded the image to openstack using this:

glance image-create --name "ubu0-kvm-img-1" --disk-format=raw --container-format=bare < {filepath}.img

Uploading was successful based on this return:

+------------------+--------------------------------------+
| Property         | Value                                |
+------------------+--------------------------------------+
| checksum         | ebcc78e5003ab94a777841f9f53dca8c     |
| container_format | bare                                 |
| created_at       | 2014-01-06T09:47:19                  |
| deleted          | False                                |
| deleted_at       | None                                 |
| disk_format      | raw                                  |
| id               | 10d2e5b9-6aac-42c9-b72a-d2c6447b946a |
| is_public        | False                                |
| min_disk         | 0                                    |
| min_ram          | 0                                    |
| name             | ubu0-kvm-img-1                       |
| owner            | 897cba47f9e241a89b2b7fe102b834e6     |
| protected        | False                                |
| size             | 10737418240                          |
| status           | active                               |
| updated_at       | 2014-01-06T09:53:26                  |
+------------------+--------------------------------------+

Also, I can view it from the openstack dashboard. Unfortunately, I have no enough karma yet to upload the snapshot. After that, I created an instance using that image and creation was successful, signified by the "running" state of the instance. It was given an IP of 10.0.0.2. I pinged it from the host machine and it can be reached. However, I cannot access it using SSH or remina or the console from the openstack dashboard. I tried to assign a floating IP and restarted it. However, this did not solve the problem.

Do you have any ideas on how to resolve this? Any feedback is greatly appreciated. Thanks in advance!

edit retag flag offensive close merge delete

Comments

what's the output of nmap 10.0.0.2 -p 22

foexle gravatar imagefoexle ( 2014-01-06 08:10:24 -0500 )edit

You don't need to upload images from the dashboard; the output of the command line tools (e.g., `glance index`) is sufficient.

larsks gravatar imagelarsks ( 2014-01-06 08:43:41 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-01-06 13:42:33 -0500

smaffulli gravatar image

Check that sshd is installed and running on the virtual image you created. In order to debug the issue, you may want to try running one of the images known to be working, like the CirrOS one: if you can connect to that, via vnc or ssh, then the trouble is in the image you created. Otherwise the problem is somewhere else.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-01-06 04:06:54 -0500

Seen: 197 times

Last updated: Jan 06 '14