Ask Your Question
0

gnocchi setup

asked 2016-11-24 20:34:49 -0500

masber gravatar image

Hi,

I am following this document http://docs.openstack.org/developer/ceilometer/install/custom.html (http://docs.openstack.org/developer/c...) to setup gnocchi, but I don't understand when it says

The value specified for archive_policy should correspond to the name of an archive_policy configured within Gnocchi.

Could someone please help me to find out what I need to put on my gnocchi.conf file?

I have:

ceilometer.conf

[dispatcher_gnocchi]

archive_policy = low

gnocchi.conf

[archive_policy]

#
# From gnocchi
#

# Default aggregation methods to use in created archive policies (list value)
#default_aggregation_methods = mean,min,max,sum,std,median,count,95pct

thank you very much

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
1

answered 2016-11-25 04:09:27 -0500

yprokule gravatar image

@masber - it basically says - the policy's name you specify in ceilometer.conf must be configured in Gnocchi, not in gnocchi.conf

So create an archive-policy, like:

gnocchi archive-policy create \
    -b 0 -m min -m mean -m max -m count \
    -d 'points:5,granularity:60' \
    -d 'points:3,timespan:900' \
    -d 'timespan:3600,granularity:900' \
    -d 'points:24,granularity:3600' \
    my-low

than specify my-low in your ceilometer.conf

edit flag offensive delete link more

Comments

wouldn't be easier to use a predefined one? I think this is what the document is trying to say

masber gravatar imagemasber ( 2016-11-26 21:07:54 -0500 )edit

Feel free to use default one :)

yprokule gravatar imageyprokule ( 2016-11-28 01:09:26 -0500 )edit
0

answered 2016-11-26 21:06:58 -0500

masber gravatar image

ok, I got the answer:

you put on gnocchi.conf: archive_policy_name = high

and this on the ceilometer.conf: archive_policy = high

Basically I am using a predefined archive policy. You can create yours one as jprokule suggest.

thanks

edit flag offensive delete link more

Comments

So, in gnocchi.conf U specify archive_policy_name for gnocchi-statsd, not for usage in/with ceilometer.

yprokule gravatar imageyprokule ( 2016-11-28 01:10:42 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-11-24 20:34:49 -0500

Seen: 360 times

Last updated: Nov 26 '16