gnocchi-api fails with 403 Forbidden

asked 2016-11-24 08:18:05 -0500

Meghna gravatar image

updated 2016-11-25 03:58:48 -0500

Hi I am using kolla for deploying openstack services. I was able to deploy keystone, nova, cinder, neutron services successfully. Then I enabled gnocchi service and re-deployed all the containers with it. The gnocchi containers for services gnocchi-api, gnocchi-metricd and gnocchi-statsd are up. But when I try to use the gnocchi command line/apis it fails with 403 error.

<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>403 Forbidden</title>
</head><body>
<h1>Forbidden</h1>
<p>You don't have permission to access /v1/resource/generic
on this server.</p>
</body></html>

Can you please help me.

edit retag flag offensive close merge delete

Comments

Can you please share logs from:

docker logs gnocchi_api

and gnocchi logs present in heka containers at:

docker exec -ti heka ls /var/log/kolla/gnocchi

Are you using master branch or stable, ubuntu or centos?

Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2016-11-25 03:56:34 -0500 )edit

@Meghna - without logs it's hard to say what's going on. Please provide gnocchi's logs api/metricd. Btw, what backend is gnocchi configured to use - file/swift/ceph ? Appropriate section from gnocchi.conf would be helpfull as well.

yprokule gravatar imageyprokule ( 2016-11-25 04:05:19 -0500 )edit

Thanks Eduardo. The commands were really helpful. I am using file as a backend for gnocchi. The problem was the install_type was not binary it was source.

Meghna gravatar imageMeghna ( 2016-12-22 11:31:12 -0500 )edit

Can you please mark as answered?

Paul Bourke gravatar imagePaul Bourke ( 2017-06-16 06:13:59 -0500 )edit