Ask Your Question
0

Why is ODL adding port eth1 to br-int by default

asked 2016-11-23 13:05:08 -0500

DaveJ gravatar image

On my ODL and Openstack setup, after I configure the OVS switch to be managed by ODL, two bridges are created:

br-int and br-ex.

For some reason ODL seems to add port eth1 to br-int by default

ovs-vsctl show
1fb6f2bf-3386-49d0-8a1c-16191307b82f
    Manager "tcp:192.168.120.254:6640"
    Bridge br-int
        Controller "tcp:192.168.120.254:6653"
        fail_mode: secure
        Port "eth1"
            Interface "eth1"
                error: "could not open network device eth1 (No such device)"
        Port br-int
            Interface br-int
                type: internal
    Bridge br-ex
        Controller "tcp:192.168.120.254:6653"
        fail_mode: secure
        Port br-ex
            Interface br-ex
                type: internal
    ovs_version: "2.5.0"

On my setup I don't have eth1, instead its

enp0s3 enp0s8 enp0s9

I haven't configured eth1 anywhere, so why does this get added by default?

edit retag flag offensive close merge delete

Comments

Hi Dave, Even i observed the same while trying out Berylium integration with OpenStack Mitaka. I was removing that port from br-int manually during the course of work. BTW which ODL are you working on ? --Regrads

Praveen N gravatar imagePraveen N ( 2016-11-24 04:43:24 -0500 )edit

Hi, I'm using packstack to install Newton with ODL Boron-SR1 (but got the same behavior with Berylium). Does your system function correctly? When I create VMs sometimes they get IPs via DHCP and sometimes they don't. It's very flaky.

DaveJ gravatar imageDaveJ ( 2016-11-24 11:41:57 -0500 )edit

Hi, I used Packstack to install Mitaka. System was functional and it was working good. FYI: http://sciencecloud-community.cs.tu.a...

Praveen N gravatar imagePraveen N ( 2016-11-24 19:16:59 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-11-24 01:36:05 -0500

Arun gravatar image

can you verify your local.conf file

edit flag offensive delete link more

Comments

I'm using packstack, not devstack, so their is no local.conf here.

DaveJ gravatar imageDaveJ ( 2016-11-25 11:57:41 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-11-23 13:05:08 -0500

Seen: 273 times

Last updated: Nov 23 '16