Ask Your Question
0

Nova-compute unavailable in compute nodes. [packstack-mitaka]

asked 2016-11-23 02:20:59 -0500

M.Akmal Khairuddin gravatar image

We just deployed Openstack server with packstack mitaka.

There was no installation error. However, we are not sure any nova-compute service is either up or non-exist.

[root@controller ~(keystone_admin)]# nova service-list
+----+------------------+------------------------+----------+---------+-------+----------------------------+-----------------+
| Id | Binary           | Host                   | Zone     | Status  | State | Updated_at                 | Disabled Reason |
+----+------------------+------------------------+----------+---------+-------+----------------------------+-----------------+
| 8  | nova-cert        | controller.miitlab.net | internal | enabled | up    | 2016-11-23T08:05:44.000000 | -  |
| 9  | nova-consoleauth | controller.miitlab.net | internal | enabled | up    | 2016-11-23T08:05:43.000000 | -  |
| 10 | nova-scheduler   | controller.miitlab.net | internal | enabled | up    | 2016-11-23T08:05:43.000000 | -   |
| 11 | nova-conductor   | controller.miitlab.net | internal | enabled | up    | 2016-11-23T08:05:42.000000 | -  |
+----+------------------+------------------------+----------+---------+-------+----------------------------+-----------------+

Also here is the installation log via packstack.

50.0.0.31_api_nova.pp:                               [ DONE ]
Applying 50.0.0.31_nova.pp
Applying 50.0.0.11_nova.pp
Applying 50.0.0.12_nova.pp
50.0.0.12_nova.pp:                                   [ DONE ]
50.0.0.31_nova.pp:                                   [ DONE ]
50.0.0.11_nova.pp:                                   [ DONE ]

Another one. Configuration in packstack.

[root@controller ~(keystone_admin)]# cat answers.cfg |egrep -i 'controller_host|compute_host|network_host|storage_host|ntp_servers|sahara_host'
CONFIG_NTP_SERVERS=0.pool.ntp.org,1.pool.ntp.org,2.pool.ntp.org,3.pool.ntp.org
CONFIG_CONTROLLER_HOST=50.0.0.31
CONFIG_COMPUTE_HOSTS=50.0.0.11,50.0.0.12
CONFIG_NETWORK_HOSTS=50.0.0.21
CONFIG_STORAGE_HOST=50.0.0.41
CONFIG_SAHARA_HOST=

As conclusion, we cannot deploy an instance because there are no nova-compute in our compute nodes. Did we do something wrong in our answer file? Thank you.

edit retag flag offensive close merge delete

Comments

Please, post (upload as text somewhere)
1. /var/log/nova/compute.log (from each compute node)
2. ovs-vsctl show; ifconfig from controller,netwok,compute nodes
3. CONFIG_UNSUPPORTED value from answer file

dbaxps gravatar imagedbaxps ( 2016-11-23 03:08:41 -0500 )edit

https://drive.google.com/file/d/0B8DG55oq91HOeFdvcDY3Y3ZyQmc/view?usp=drivesdk (https://drive.google.com/file/d/0B8DG...)

You can download it from here. Thanks

M.Akmal Khairuddin gravatar imageM.Akmal Khairuddin ( 2016-11-23 11:22:23 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-11-23 13:44:41 -0500

dbaxps gravatar image

updated 2016-11-23 14:01:31 -0500

Using field as comment
Per your report on Network Node

[root@network ~]# ovs-vsctl show
230a8056-b180-48be-b6ab-7da5152b9208
    Manager "ptcp:6640:127.0.0.1"
        is_connected: true
    Bridge br-ex
        Port br-ex
            Interface br-ex
                type: internal
        Port "qg-3009da08-8a"
            Interface "qg-3009da08-8a"
                type: internal
    Bridge br-int
        Controller "tcp:127.0.0.1:6633"
            is_connected: true
        fail_mode: secure
        Port br-int
            Interface br-int

You cannot get out without having eth0(X) as port of br-ex

Check this segment in ans.cfg

CONFIG_NEUTRON_ML2_TYPE_DRIVERS=vxlan
CONFIG_NEUTRON_ML2_TENANT_NETWORK_TYPES=vxlan
CONFIG_NEUTRON_ML2_MECHANISM_DRIVERS=openvswitch
CONFIG_NEUTRON_ML2_FLAT_NETWORKS=*
CONFIG_NEUTRON_ML2_VLAN_RANGES=
CONFIG_NEUTRON_ML2_TUNNEL_ID_RANGES=1001:2000
CONFIG_NEUTRON_ML2_VXLAN_GROUP=239.1.1.2
CONFIG_NEUTRON_ML2_VNI_RANGES=1001:2000
CONFIG_NEUTRON_L2_AGENT=openvswitch
CONFIG_NEUTRON_LB_INTERFACE_MAPPINGS=
CONFIG_NEUTRON_OVS_BRIDGE_MAPPINGS=physnet1:br-ex
CONFIG_NEUTRON_OVS_BRIDGE_IFACES=
CONFIG_NEUTRON_OVS_TUNNEL_IF=eth1
CONFIG_NEUTRON_OVS_VXLAN_UDP_PORT=4789

You skipped CONFIG_NEUTRON_OVS_BRIDGE_MAPPINGS to be assigned correct value You can update answer file from http://dbaxps.blogspot.com/2015/10/rd...
as you need regarding adding storage node and updating eth(X) matching your names.

edit flag offensive delete link more

Comments

CONFIG_NEUTRON_OVS_BRIDGE_MAPPINGS=physnet1:br-int CONFIG_NEUTRON_OVS_BRIDGE_IFACES=br-int:eth1 CONFIG_NEUTRON_OVS_BRIDGES_COMPUTE=br-int

is it correct? we use eth1 at all compute nodes to establish connection to br-int network node.

M.Akmal Khairuddin gravatar imageM.Akmal Khairuddin ( 2016-11-23 21:02:39 -0500 )edit

I guess that is not correct. No matter do you use bridged or non-bridged external networking

dbaxps gravatar imagedbaxps ( 2016-11-23 23:52:35 -0500 )edit

You wrote:- we use eth1 at all compute nodes to establish connection to br-int network node
Packstack been run with correct answer-file establish VXLAN tunnels between Compute and Network Nodes , interface been used for VTEP is defined by
CONFIG_NEUTRON_OVS_TUNNEL_IF

dbaxps gravatar imagedbaxps ( 2016-11-24 00:10:43 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-11-23 02:20:59 -0500

Seen: 293 times

Last updated: Nov 23 '16