Neutron config endpoint_type not take effect. [closed]

asked 2016-11-22 01:55:14 -0600

Jack Ji gravatar image

Hi guys, We try to setup a https evironment for openstack liberty version, other parts are success except Neutron. We try to configure the neturn.conf property endpoint_type to be: endpoint_type = publicURL (Because the public endpoint for neutron is https). And then restart the neutron service. But the retrun value is still point to the previous one:
Command: curl -k https://controll:19696
Result: {"versions": [{"status": "CURRENT", "id": "v2.0", "links": [{"href": "http://controller:9696/v2.0", "rel": "self"}]}]}
I also try to set the property endpoint_type to be endpoint_url = https://controller:19696. But it still failed.
Does anybody have some idea about this to configure the neutron endpoint?

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by rbowen
close date 2016-11-30 10:10:33.398489

Comments

Duplicate posting

rbowen gravatar imagerbowen ( 2016-11-30 10:10:30 -0600 )edit