Ask Your Question
0

Config Neutron endpoint_type not take effect

asked 2016-11-22 01:45:22 -0600

Jack Ji gravatar image

updated 2016-11-30 10:10:05 -0600

rbowen gravatar image

Hi guys, We try to setup a https evironment for openstack liberty version, other parts are success except Neutron. We try to configure the neturn.conf property endpoint_type to be: endpoint_type = publicURL (Because the public endpoint for neutron is https). And then restart the neutron service. But the retrun value is still point to the previous one:

Command: curl -k https://controll:19696

Result: {"versions": [{"status": "CURRENT", "id": "v2.0", "links": [{"href": "http://controller:9696/v2.0", "rel": "self"}]}]}

I also try to set the property endpoint_type to be endpoint_url = https://controller:19696. But it still failed. Does anybody have some idea about this to configure the neutron endpoint?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-11-30 18:56:41 -0600

Bernd Bausch gravatar image

According to the config guide, endpoint_type has nothing to do with the Neutron endpoint:

endpoint_type = public (String) Type of the nova endpoint to use. This endpoint will be looked up in the keystone catalog and should be one of public, internal or admin.

I don't see a config variable named endpoint_url.

On the other hand, from the same config guide:

bind_port = 9696 (Port number) The port to bind to

and from the install guide:

openstack endpoint create --region RegionOne network public http://controller:9696
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2016-11-22 01:45:22 -0600

Seen: 55 times

Last updated: Nov 30 '16