No limit value provided, result set will be limited to 100

asked 2016-11-16 22:05:34 -0500

WangLiwei gravatar image

updated 2016-11-17 08:09:57 -0500

when i use kolla to deploy openstack, I choose the ceilometer service, but I have met this error in ceilometer-api.log:

[Thu Nov 17 02:16:07.799718 2016] [:info] [pid 19] mod_wsgi (pid=19): Create interpreter '172.16.100.231:8777|'. [Thu Nov 17 02:16:07.802619 2016] [:info] [pid 19] mod_wsgi (pid=19): Adding '/var/lib/kolla/venv/lib/python2.7/site-packages' to path. [Thu Nov 17 02:16:07.805611 2016] [:info] [pid 19] [remote 172.16.100.231:188] mod_wsgi (pid=19, process='ceilometer-api', application='172.16.100.231:8777|'): Loading WSGI script '/var/lib/kolla/venv/lib/python2.7/site-packages/ceilometer/api/app.wsgi'. [Thu Nov 17 02:16:10.683603 2016] [:error] [pid 19] 2016-11-17 02:16:10.682 19 INFO ceilometer.api.app [-] Full WSGI config used: /etc/ceilometer/api_paste.ini [Thu Nov 17 02:16:10.760994 2016] [:error] [pid 19] 2016-11-17 02:16:10.760 19 INFO ceilometer.storage.mongo.utils [-] Connecting to mongodb on [('172.16.100.231', 27017)] [Thu Nov 17 02:16:10.780751 2016] [:error] [pid 19] 2016-11-17 02:16:10.780 19 INFO ceilometer.storage.mongo.utils [-] Connecting to mongodb on [('172.16.100.231', 27017)] ....... [Thu Nov 17 02:16:52.155399 2016] [:error] [pid 17] 2016-11-17 02:16:52.153 17 INFO ceilometer.api.controllers.v2.utils [-] No limit value provided, result set will be limited to 100.

in kolla/gloabals.yml ceilometer_database_type: "mongodb"

edit retag flag offensive close merge delete

Comments

Hi, I am not sure what the question is, but in order to understand 'no limit provided' you can read http://developer.openstack.org/api-gu...

volenbovsky gravatar imagevolenbovsky ( 2016-11-17 04:29:27 -0500 )edit

@volenbovsky , thank you! But this can not solve my question. The config.json has not any href option to set the limit.

WangLiwei gravatar imageWangLiwei ( 2016-11-17 07:53:20 -0500 )edit

2 answers

Sort by » oldest newest most voted
0

answered 2016-11-18 05:45:07 -0500

volenbovsky gravatar image

Hi,

it actually sounds as problem connecting to MongoDB. So you should double-check authentication/connection data defined in Ceilometer (connection = in [database]) and try to connect to MongoDB using credentials you defined manually.

edit flag offensive delete link more
0

answered 2016-11-18 03:26:32 -0500

Shaoman Zhang gravatar image

This is not a error, now ceilometer-api limit the number of results per request, the default is 100. If you want change the number, try to modify default_api_return_limit in ceilometer.conf.

edit flag offensive delete link more

Comments

Thank you. But after i add default_api_return_limit=100000 in ceilometer.conf. The log error changed to No limit value provided, result set will be limited to 100000.. So I thought maybe something wrong in other place.

WangLiwei gravatar imageWangLiwei ( 2016-11-19 20:01:49 -0500 )edit

You modified the default limit value, but the command did not specify the "limit" parameters, so there is still such a print. If you do not want to see this print, you can try to execute the command: ceilometer meter-list -l 500

Shaoman Zhang gravatar imageShaoman Zhang ( 2017-06-29 06:03:38 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-11-16 22:05:34 -0500

Seen: 384 times

Last updated: Nov 18 '16