Ask Your Question
0

glance-api and registry services not starting

asked 2016-11-16 10:35:53 -0600

DarkKnight gravatar image

I am noticing that the glance api and the registry services are unable to start on my openstack setup. I have installed openstack mitalka with the compute and the controller on the same node. This setup had been functional for the last 3 months, but now has been giving many issues.

I am pasting the confiiguration files for glance here.

[root@localhost glance(keystone_admin)]# grep -v -e '^#' -e '^$' /etc/glance/glance-api.conf
[DEFAULT]
show_image_direct_url = False
bind_host = 0.0.0.0
bind_port = 9292
workers = 24
backlog = 4096
image_cache_dir = /var/lib/glance/image-cache
registry_host = 10.1.10.22
registry_port = 9191
registry_client_protocol = http
debug = True
verbose = True
log_file = /var/log/glance/api.log
log_dir = /var/log/glance
use_syslog = False
syslog_log_facility = LOG_USER
use_stderr = True
notification_driver=messaging
[cors]
[cors.subdomain]
[database]
connection = mysql+pymysql://glance:glance123@10.1.10.22/glance
[glance_store]
stores = file,http,swift
default_store = file
filesystem_store_datadir = /var/lib/glance/images/
os_region_name=RegionOne
[image_format]
[keystone_authtoken]
auth_uri = http://10.1.10.22:5000/v2.0
identity_uri=http://10.1.10.22:35357
admin_password=glance123
admin_tenant_name=services
admin_user=glance
[matchmaker_redis]
[oslo_concurrency]
[oslo_messaging_amqp]
[oslo_messaging_notifications]
[oslo_messaging_rabbit]
amqp_durable_queues = False
rabbit_host = 10.1.10.22
rabbit_port = 5672
rabbit_hosts = 10.1.10.22:5672
rabbit_use_ssl = False
rabbit_userid = guest
rabbit_password = guest
rabbit_virtual_host = /
rabbit_ha_queues = False
heartbeat_timeout_threshold = 0
heartbeat_rate = 2
rabbit_notification_exchange=glance
rabbit_notification_topic=notifications
[oslo_policy]
[paste_deploy]
flavor = keystone
[profiler]
[store_type_location_strategy]
[task]
[taskflow_executor]
===========

I have tried to manually start the glance api service, but that is also failing

====

[root@localhost glance(keystone_admin)]# /usr/bin/glance-api
/usr/lib/python2.7/site-packages/oslo_middleware/ssl.py:28: DeprecationWarning: The 'oslo_middleware.ssl' module usage is deprecated, please use oslo_middleware.http_proxy_to_wsgi instead
  "oslo_middleware.http_proxy_to_wsgi")
Option "verbose" from group "DEFAULT" is deprecated for removal.  Its value may be silently ignored in the future.
ERROR: Unable to locate paste config file for glance-api.
[root@localhost glance(keystone_admin)]#

====================

Which is the paste-config file that this is referring to?

I am also not getting any error message in the glance-api and the glance-registry logs. Can someone tell how to debug this. This is very urgent

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2016-11-16 20:48:48 -0600

silently gravatar image

do you have this file : /etc/glance/glance-api-paste.ini ?

edit flag offensive delete link more
0

answered 2016-11-16 10:50:40 -0600

DarkKnight gravatar image

The glance issue was fixed by referring to a link. I am pasting it here for others https://techglimpse.com/openstack-ins...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-11-16 10:35:53 -0600

Seen: 949 times

Last updated: Nov 16 '16