CPU over-provisioning settings in mitaka [closed]

asked 2016-11-16 04:30:44 -0600

AB239 gravatar image

Hello all,

I have successfully installed Mitaka release of OpenStack on Ubuntu 14.04 OS in distributed environment. I have a compute node of 24 cores and I am trying to launch a STACK of around 45 VMs. I have an impression that by default there is 16:1 cpu over-provisioning enabled but I am unable to launch 45 VMs.

Getting this error: "no valid host was found. there are not enough hosts available. code 500" and few VMs fail to start.

Please guide me if my assumption of a 16:1 cpu_allocation_ratio is correct or I need to explicitly configure it in nova.conf Also, how can I check what is current setting for Mitaka.

Any links that explain this concept in more detail will be highly appreciated.

Regards AB

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by AB239
close date 2017-04-04 04:19:03.942225

1 answer

Sort by ยป oldest newest most voted

answered 2016-11-16 07:14:28 -0600

Yes, it's 16 by default, and it can be configured. See http://docs.openstack.org/newton/conf.... To find out which filter removed your node when scheduling, switch on DEBUG logging, run the test again and see the filter messages in the nova-scheduler.log.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2016-11-16 04:30:44 -0600

Seen: 686 times

Last updated: Nov 16 '16