Ask Your Question
0

publicurl endpoint for image not found [closed]

asked 2014-01-04 18:54:54 -0500

slimix00 gravatar image

updated 2014-01-05 15:21:26 -0500

Hi everyone ! happy new year

I'm configuring the glance service. and this is the command for creating the glance image : #glance --os-username=admin --os-password=cloud --os-tenant-name=admin --os-auth-url=http://controller:5000/v2.0 image-create --name="precise-server-cloudimg" --disk-format=qcow2 --container-format bare < precise-server-cloudimg-i386-vagrant-disk1.box

=>>>> I'm obtainnig that result publicurl endpoint for image not found

what can i do plz knownig that I had defined the image service by doing this :

keystone service-create --name=glance --type=image --description="Image Service" :

+-------------+----------------------------------+ | Property | Value | +-------------+----------------------------------+ | description | Image Service | | id | 7d5258c490144c8c92505267785327c1 | | name | glance | | type | image | +-------------+----------------------------------+

$ keystone endpoint-create \ --region RegionOne \ --service-id=7d5258c490144c8c92505267785327c1 \ --publicurl=http://192.168.206.130:9292 \ --internalurl=http://192.168.206.130:9292 \ --adminurl=http://192.168.206.130:9292

+-------------+-----------------------------------+ | Property | Value | +-------------+-----------------------------------+ | adminurl | http://192.168.206.130:9292 | | id | 3c8c0d749f21490b90163bfaed9befe7 | | internalurl | http://192.168.206.130:9292 | | publicurl | http://192.168.206.130:9292 | | region | RegionOne | | service_id | 7d5258c490144c8c92505267785327c1 | +-------------+-----------------------------------+

Thank's in advance

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by dheeru
close date 2014-01-14 07:03:04.881511

2 answers

Sort by ยป oldest newest most voted
1

answered 2014-01-04 20:49:38 -0500

dheeru gravatar image

updated 2014-01-04 20:50:32 -0500

issue is about --region RegionOne. While creating the image pass --region argument also. By default it takes 'regionOne'. Observe lower case 'r'.

glance --region RegionOne --os-username=admin --os-password=cloud --os-tenant-name=admin --os-auth-url=http://controller:5000/v2.0 image-create --name="precise-server-cloudimg" --disk-format=qcow2 --container-format bare < precise-server-cloudimg-i386-vagrant-disk1.box

edit flag offensive delete link more
0

answered 2014-01-05 14:06:54 -0500

slimix00 gravatar image

updated 2014-01-06 12:16:21 -0500

Hi thank you for your answer SIR !

Excuse me but I think you did a mistake ( the command should be "--os-region-name=regionOne" because I tried the other one " --region RegionOne " and they tell me to change the syntax of the command.

1) regionOne

glance --os-region-name=regionOne --os-username=admin --os-password=cloud --os-tenant-name=admin --os-auth-url=http://controller:5000/v2.0 \image-create --name="ubuntu server cloudimg" --disk-format=qcow2 --container-format bare < ubuntu-12.04-server-cloudimg-i386-disk1.img

publicURL endpoint for image not found.

2) RegionOne (with capital letter)

glance --os-region-name=RegionOne --os-username=admin --os-password=cloud --os-tenant-name=admin --os-auth-url=http://controller:5000/v2.0 \image-create --name="ubuntu server cloudimg" --disk-format=qcow2 --container-format bare < ubuntu-12.04-server-cloudimg-i386-disk1.img

Request returned failure status. Invalid OpenStack Identity credentials.

(athentication error so the right one is the first command (regionOne))

But I still have the same message publicURL endpoint for image not found (can you explain to me what does it mean ? please)

//////////////////////////////////////////////////////////////////////////// 06/01/2014

Hi !

I was expecting to send you this message before your last responce (I didn't send it because It wasn't clear on comment zone) I thought that I have to wait for you answer in a way to respond you normallay.

SO I still don't know why only one responce is allowed per user !!!!!! Here is my message

[[[[[[[[[ You were right sir, It's about regionONE

Well ! I solved the problem Actually when I created the endpoint for glance service with this command : keystone endpoint-create --region RegionOne --service-id=7d5258c490144c8c92505267785327c1 --publicurl=http://controller:9292 --internalurl=http://192.168.206.130:9292 --adminurl=http://controller:9292

=>>>>>as you can see "RegionOne" is with capital letter

BUT before that I had created the endpoint for identity service without putting that command --region RegionOne ....So by default it tooks (regionOne and not RegionOne)

So there was a contradiction between the 2 services So I deleted the endpoint for glance service with this way :

I needed to know the id of endpoints by this command

1/ #keystone endpoint-list (this command shows every endpoint created with its ID)

2/ #keystone endpoint-delete [we put here the id of the endpoint that we want to delete and recreate it ]

I recreated another endpoint for glance service without --region RegionOne

I put the special command

#glance --os-username=admin --os-password=cloud --os-tenant-name=admin --os-auth-url=http://controller:5000/v2.0 --os-region-name=regionOne \image-create --name="ubuntu server cloudimg" --disk-format=qcow2 --container-format bare < ubuntu-12.04-server-cloudimg-i386-disk1.img

I don't have the old error but another one ! Oups Request returned failure status. Invalid OpenStack Identity credentials.

Even I think that I configured the credentials with the right way. what should I do plz ]]]]]]]]]]

edit flag offensive delete link more

Comments

1

it is --os-regione-name. You are right. It is my bad. Now your second option is right. you created the endpoint with RegionOne as argument as look at your endpoint list (region | RegionOne | | service_id). You can do the following. Delete Service and endpoints altogether. Create new service and endpoint without giving any region argument. This should solve your issue. If not, let us have chat session and I will help you to resolve this issue.

dheeru gravatar imagedheeru ( 2014-01-05 21:32:17 -0500 )edit

I put the answer of this comment with my second POST, in a way to have a clear message Thank's

slimix00 gravatar imageslimix00 ( 2014-01-06 12:17:12 -0500 )edit

I have another question please....I put the same password for identity service and glance service......Could it be the problem ?

slimix00 gravatar imageslimix00 ( 2014-01-06 15:51:03 -0500 )edit

Problem solved wow I'm happy..it's not about the pass ...It's beause I didn't create the "glance user " hhhh by this command : # keystone user-create --name=glance --pass=glance pass S \ --email=glance@example.com # keystone user-role-add --user=glance --tenant=service --role=admin

slimix00 gravatar imageslimix00 ( 2014-01-06 17:36:46 -0500 )edit

because i was following that stupid documentation (there is 2 versions or more) ...you can see in the first link.....they didn't mention the glance user http://docs.openstack.org/grizzly/openstack-compute/install/apt/content/configure-glance-mysql.html%3C/p%3E (http://docs.openstack.org/grizzly/openstack-compute/install/apt/content/configure-glance-mysql.html)

slimix00 gravatar imageslimix00 ( 2014-01-06 17:38:58 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-01-04 18:54:54 -0500

Seen: 5,299 times

Last updated: Jan 06 '14