Ask Your Question
1

How can I know which release of Openstack is iam using?

asked 2016-11-15 10:14:54 -0500

vathanlal gravatar image

updated 2016-11-15 10:15:25 -0500

How can I know which release of openstack is iam using?? I have openstack commands on terminal.

openstack --version
openstack 3.2.0

I dont know which release is Openstack 3.2.0. Is there any particular command to identify the release?? Please help.

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
1

answered 2016-11-15 10:48:03 -0500

updated 2016-11-15 13:01:36 -0500

Hey vathanlal,

There are a few ways to check what version you are running. Your client check will let you know which version of OpenStack the client was released under - http://docs.openstack.org/releasenote...

Regarding OpenStack itself, you can check on one of your compute nodes the nova-compute service for example against the release info for example - https://releases.openstack.org/ - https://releases.openstack.org/newton/ :

nova 14.0.0 14.0.2 release notes

(nova-14.0.2) root@compute01:~# nova-compute --version 14.0.3

You can check other services as well as noted by the releases.openstack.org/{release} link but I prefer to use nova-compute since it is a core project and in my view going to probably follow the same standard.

edit flag offensive delete link more

Comments

A bit of minor correction - OpenStack client version (such as 3.2.0 above) is not indicating OpenStack release OSC client is compatible with (...)

volenbovsky gravatar imagevolenbovsky ( 2016-11-15 11:48:09 -0500 )edit

(...) rather it indicates the version of client released _at time_ of OpenStack release. So newest client should have no problem working towards older releases of OpenStack. Otherwise those having 'one client' but connecting towards multiple OpenStack installations would have hard time

volenbovsky gravatar imagevolenbovsky ( 2016-11-15 11:50:55 -0500 )edit

Absolutely right, updated, I mis-spoke.

mrhillsman gravatar imagemrhillsman ( 2016-11-15 12:59:07 -0500 )edit

Thanks.. This helps me..

vathanlal gravatar imagevathanlal ( 2016-11-18 04:33:44 -0500 )edit
1

answered 2016-11-15 12:53:30 -0500

dbaxps gravatar image
[root@overcloud-controller-0 ~]# nova-manage --version
14.0.3
edit flag offensive delete link more

Comments

This is not working for me.. because it gives me The program 'nova-manage' is currently not installed. You can install it by typing: apt install nova-common..

vathanlal gravatar imagevathanlal ( 2016-11-18 04:34:35 -0500 )edit

Are you end user of OpenStack cloud (=have access only via API) or administrator (=have access to servers running OpenSta)? 'nova-manage' is intended for latter. In case you are end user - maybe my answer in https://ask.openstack.org/en/question... will be of help

volenbovsky gravatar imagevolenbovsky ( 2016-11-18 06:16:45 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-11-15 10:14:54 -0500

Seen: 2,991 times

Last updated: Nov 15 '16