Ask Your Question

Error: [$injector:modulerr] Failed to instantiate module due to: [$injector:nomod] Module '' is not available!

asked 2016-11-15 08:47:41 -0600

vathanlal gravatar image

updated 2016-11-15 09:04:49 -0600

I tried to install horizon using puppet openstack/horizon. But iam getting only a minimal view while login into the horizon. I also have this error when taking console by inspecting element in the browser.

Error: [$injector:modulerr] Failed to instantiate module due to:
[$injector:nomod] Module '' is not available! You either misspelled the module name or forgot to load it. If registering a module ensure that you specify the dependencies as the second argument.

I also have this error in /var/log/apache2/horizon_error.log

Could not process panel theme_preview: Dashboard with slug "developer" is not registered.

I dont know what is causing this issue. Any help is really appreciated..

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted

answered 2019-06-11 20:39:03 -0600

Adding solution here 2.5 years later - because I had same issue today. The dashboard is a django application that compiles a compressed javascript file, and for me, that javascript file wasn't compiled correctly.

Find your django application -- for me it is at /usr/share/openstack-dashboard -- and run this:

./ compress --force

then restart the web server (e.g. "service apache2 restart")

Also check the permissions in /usr/share/openstack-dashboard. You may want to change the owner to the account running the web server -- which could be "horizon", "www-data" or another account.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2016-11-15 08:47:41 -0600

Seen: 1,609 times

Last updated: Nov 15 '16