Ask Your Question
0

Lbaasv2 cookie sessions not working as haproxy( which is backend for lbaas) no longer supports appsession....any workarounds ?

asked 2016-11-10 10:22:42 -0500

Kishore448 gravatar image

I have deployed lbaasv2 and launched bunch of load balancers.

For one of them, I need to configure cookie sessions. When I added it through cli

neutron lbaas-pool-update poolid --session-persistence type=dict type=APP_COOKIE,cookie_name=sessionid

I see errors in logs stating "appsession" is no longer supported by haproxy

Seems appsession is deprecated in haproxy but lbaas still uses it configure the sessions in the backedn haproxy configs

Tried editing it manually in backend but lbaas quickly overwrites it.

Any help would be appreciated....

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2017-03-22 11:38:14 -0500

johnsom gravatar image

This is a problem if you are using the old haproxy driver and is tracked on this bug: https://bugs.launchpad.net/octavia/+b...

This changed in HAproxy versions starting with 1.6, so if you have haproxy 1.6 or newer installed the old haproxy driver has this problem.

This is not a problem with the octavia driver.

Michael

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-11-10 10:22:42 -0500

Seen: 111 times

Last updated: Mar 22 '17