Issue in flat networking two-node / icehouse

asked 2016-11-09 11:27:44 -0500

Raja gravatar image

updated 2016-11-23 12:34:48 -0500

rbowen gravatar image

Hi,

I'm not able to ping the VMs (eth1 is being used as VM traffic). Like I'm trying to ping the VM from 10.10.10.0 network to 30.30.30.0 network but no success. Even pinging to the gateway is having issue.

Please guide me if any thing wrong in the configuration:

From controller:

  # less /etc/neutron/plugin.ini

[ml2]
tenant_network_types = local,vlan,gre,vxlan
mechanism_drivers = openvswitch
enable_security_group = True

[ovs]
flat_networks = eth1
bridge_mappings = eth3:br-ex,eth1:br-eth1

[root@controller1 ~(keystone_admin)]# ovs-vsctl show
11ccc131-ea29-47a7-9b31-f85ec75d97b1
    Bridge br-ex
        Port br-ex
            Interface br-ex
                type: internal
        Port "eth3"
            Interface "eth3"
    Bridge br-int
        fail_mode: secure
        Port "tapa9d92edd-e3"
            tag: 1
            Interface "tapa9d92edd-e3"
                type: internal
        Port "qr-06ab148c-11"
            tag: 2
            Interface "qr-06ab148c-11"
                type: internal
        Port "tap2c5ca56f-26"
            tag: 2
            Interface "tap2c5ca56f-26"
                type: internal
        Port "tap79f6b7e1-9a"
            tag: 4095
            Interface "tap79f6b7e1-9a"
                type: internal
        Port br-int
            Interface br-int
                type: internal
        Port "qr-cc53dc22-93"
            tag: 1
            Interface "qr-cc53dc22-93"
                type: internal
    Bridge br-tun
        Port br-tun
            Interface br-tun
                type: internal
    Bridge "br-eth1"
        Port "eth1"
            Interface "eth1"
        Port "br-eth1"
            Interface "br-eth1"
                type: internal
    ovs_version: "1.11.0"

[root@controller1 ~(keystone_admin)]# ip netns
qrouter-80bece3b-d7e0-42ed-9721-db7652fd6a25
qdhcp-39a4fb7b-36ba-43e2-b38e-f859b456149d
qdhcp-a2c71bbc-eb72-4fd2-b9e6-1ea47a6c1f2f
qdhcp-fd9806aa-ebe4-4e13-a512-4dc0915dd23b

[root@controller1 ~(keystone_admin)]# ip netns exec qrouter-80bece3b-d7e0-42ed-9721-db7652fd6a25 ifconfig
lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

qr-cc53dc22-93 Link encap:Ethernet  HWaddr FA:16:3E:55:46:E9
          inet addr:10.10.10.1  Bcast:10.10.10.255  Mask:255.255.255.0
          inet6 addr: fe80::f816:3eff:fe55:46e9/64 Scope:Link
          UP BROADCAST RUNNING  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:10 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b)  TX bytes:684 (684.0 b)

qr-06ab148c-11 Link encap:Ethernet  HWaddr FA:16:3E:0B:47:EE
          inet addr:30.30.30.1  Bcast:30.30.30.255  Mask:255.255.255.0
          inet6 addr: fe80::f816:3eff:fe0b:47ee/64 Scope:Link
          UP BROADCAST RUNNING  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:11 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b)  TX bytes:762 (762.0 b)

From compute node:

less /etc/neutron/plugin.ini

[ml2]
tenant_network_types = local,vlan,gre,vxlan
mechanism_drivers = openvswitch
enable_security_group = True

[ovs]
flat_networks = eth1
bridge_mappings = eth1:br-eth1

[root@compute1 ~]# ovs-vsctl show
462f7bdb-c6a8-4152-b615-3d1338dd2cd9
    Bridge br-tun
        Port br-tun
            Interface br-tun
                type: internal
    Bridge br-int
        fail_mode: secure
        Port "qvo4a6864a0-ec"
            tag: 1
            Interface "qvo4a6864a0-ec"
        Port "qvo9bf39bc4-35"
            tag: 2
            Interface "qvo9bf39bc4-35"
        Port br-int
            Interface br-int
                type: internal
    Bridge "br-eth1"
        Port "eth1"
            Interface "eth1"
        Port "br-eth1"
            Interface "br-eth1"
                type: internal


bridge name     bridge id               STP enabled     interfaces ...
(more)
edit retag flag offensive close merge delete

Comments

This bridge_mappings = eth3:br-ex,eth1:br-eth1 looks wrong. The parts before the colon should be your symbolic names of the physical networks, which you then use in the neutron net-create command to create the virtual network and map it to the physical one. How did you create the virtual networks?

Bernd Bausch gravatar imageBernd Bausch ( 2016-11-24 06:43:38 -0500 )edit

See also the Networking Guide, in particular provider network setup instructions http://docs.openstack.org/newton/netw... (unfortunately, no guide for Icehouse available afaik).

Bernd Bausch gravatar imageBernd Bausch ( 2016-11-24 06:45:03 -0500 )edit