Ask Your Question
1

MTU size issue

asked 2016-11-09 10:08:54 -0500

satish.lx gravatar image

We have 3 node cluster on Mikata openstack and we are using DVR network. Recently we build two puppetmaster server on openstack and put them behind Lbaasv2 load-balancer to share load but i found my none of client able to talk to correctly with puppetmaster server on openstack. After lots of research found openstack VM use mtu 1400 and my rest of puppet agent server who are not on openstack they used mtu 1500.

as soon as i change puppet agent MTU size to 1400 everything started working. But just surprised why openstack use 1400 for VM there must be a reason like vxlan or GRE.

So for experiment i change mtu 1500 on puppetmaster server on openstack but it didn't help. How do i fix this issue?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-11-11 22:45:00 -0500

diltram gravatar image

By default, the neutron is using VLAN networks but you can also use VXLAN and GRE. Because of this your network MTU is decreased for the amount of max 50. Based on that you should increase underlying networking MTU to 1550 to not have any problems with this and use just normal world MTU everywhere - 1500.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-11-09 10:08:54 -0500

Seen: 476 times

Last updated: Nov 11 '16