Ask Your Question
1

horizon ..so i broke the dashboard.. [closed]

asked 2016-11-08 21:39:01 -0600

updated 2016-11-10 18:04:33 -0600

UPDATE: After changing local_settings identity version to 2, I was able to login but i am missing the view for roles and groups

Changed back to 3 and still unable to login....

Attaching screen shots:

C:\fakepath\openstack_login1.png

C:\fakepath\openstack_login2.png

C:\fakepath\openstack_login3.png

C:\fakepath\openstack_login4.png

#

CentOS7 mitaka, everything is working but the dashboard, validated by raising instance with mapped volume and reserved ip address...

openstack command line client works like a charm. Horizon logs in successfully but just redirects me back to the login page..... Checked httpd/.log and horizon/.log while making the request, things seem to go alright but what do i know seems like a bit of redirects and something somewhere is going wrong.

Tried removing and reinstalling horizon to reset to default. now i'm back to original logos and all that but still cant login....

Posting request logs:

2016-11-09 03:24:20,065 26998 WARNING openstack_auth.utils The settings.py file points to a v2.0 keystone endpoint, but v3 is specified as the API version to use. Using v3 endpoint for authentication.
    2016-11-09 03:24:20,686 26998 WARNING openstack_auth.utils The settings.py file points to a v2.0 keystone endpoint, but v3 is specified as the API version to use. Using v3 endpoint for authentication.
    2016-11-09 03:24:20,687 26998 INFO openstack_auth.forms Login successful for user "bcollins".
    10.212.134.200 - - [08/Nov/2016:22:24:20 -0500] "POST /dashboard/auth/login/ HTTP/1.1" 302 - "https://portal.orbit8.com/dashboard/auth/login/?next=/dashboard/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/54.0.2840.90 Safari/537.36"
    10.212.134.200 - - [08/Nov/2016:22:24:20 -0500] "GET /dashboard/ HTTP/1.1" 302 - "https://portal.orbit8.com/dashboard/auth/login/?next=/dashboard/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/54.0.2840.90 Safari/537.36"
    10.212.134.200 - - [08/Nov/2016:22:24:20 -0500] "GET /dashboard/auth/login/?next=/dashboard/ HTTP/1.1" 200 2789 "https://portal.orbit8.com/dashboard/auth/login/?next=/dashboard/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/54.0.2840.90 Safari/537.36"
    10.212.134.200 - - [08/Nov/2016:22:24:21 -0500] "GET /dashboard/static/dashboard/css/34f8a8f8d5e5.css HTTP/1.1" 200 4428 "https://portal.orbit8.com/dashboard/auth/login/?next=/dashboard/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/54.0.2840.90 Safari/537.36"
    10.212.134.200 - - [08/Nov/2016:22:24:21 -0500] "GET /dashboard/static/dashboard/css/235e58420082.css HTTP/1.1" 200 53528 "https://portal.orbit8.com/dashboard/auth/login/?next=/dashboard/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/54.0.2840.90 Safari/537.36"
    10.212.134.200 - - [08/Nov/2016:22:24:21 -0500] "GET /dashboard/static/dashboard/js/7fd3f7d69c71.js ...
(more)
edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by bcollins
close date 2016-11-10 18:18:55.679011

Comments

There is no solid troubleshooting guide for horizon or issues like this.

bcollins gravatar imagebcollins ( 2016-11-10 17:30:20 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-11-10 18:18:42 -0600

Answered before in this post. SESSION_ENGINE='django.contrib.sessions.backends.cache'

added and api v3 can be used again......

https://ask.openstack.org/en/question...

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-11-08 21:39:01 -0600

Seen: 1,493 times

Last updated: Nov 10 '16