Ask Your Question
1

Console instance not accepting ":" char

asked 2014-01-03 11:08:09 -0500

eshine gravatar image

updated 2014-01-22 15:13:06 -0500

Evgeny gravatar image

Hi!

When I launch a new instance (tiny, small) it booted OK and I was able to get a login prompt (Cirros login:). However, the console don't accept ":" char, that is one char of default cirros password. Most of chars accept shift+key, but some don't accept shift key, for example I can type "[", but not "{" that is the char for shift + [ keys. Some special chars are yet accepted, like "<" (shift + ,). I'm using fresh devstack deployment in Ubuntu 12.4 LTS (started with minimal package), controller and compute server for test in the same VM. I've tried access using different VMs (Windows/Chrome and Ubuntu/Firefox) with the same behaviour.

Please let me know if you need more specific info about this environment.

Thanks in advance for your time.

edit retag flag offensive close merge delete

6 answers

Sort by » oldest newest most voted
3

answered 2014-01-16 10:15:03 -0500

nati-ueno gravatar image

updated 2014-01-16 11:47:16 -0500

This looks like a bug in noVNC. I have reported this bug to the noVNC github issues.

https://github.com/kanaka/noVNC/issues/331

Updated

It is fixed in master, so please update your git repo for noVNC

edit flag offensive delete link more

Comments

I have heard in Japanese keyboard characters they also have some issues with : character as well.

Moe gravatar imageMoe ( 2015-09-29 22:12:48 -0500 )edit
1

answered 2015-05-27 18:24:17 -0500

hnhillol gravatar image

I have an alternative solution to this problem , if someone is facing problem typing ":" and ")" while giving password for cirros . here is the alt keyboard sequence link http://tools.oratory.com/altcodes.html , please type your desired characters value followed by alt , they will type twice ( dont know why ) , delete one and keep the rest . for example if you type alt+58 you will get in your console :; delete later one and keep only ":" . Please suggest if anybody get a permanent solution to this . Regards,

edit flag offensive delete link more
0

answered 2017-05-15 05:33:10 -0500

amelia gravatar image

what worked for me was Alt+ right shift+: to print the char":" and left shift+à to print the char ")" (i have a french keyboard azerty). hope that it can help someone else!

edit flag offensive delete link more
0

answered 2018-08-05 04:55:58 -0500

set your keyboard EN https://en.wikipedia.org/wiki/QWERTY
then : can be reach with right shit+ ) with shit+0 w with z

reset password : passwd old password : <retype the="" good="" english="" sequence="" &gt;="" new="" password="" :="" <switch="" your="" keyboard="" in="" french="" &gt;="" &lt;="" type="" password="" with="" french="" valid="" keys="" like="" cubswin:)&gt;="" <br=""> confirm exit retry with cubswin:) it works enjoy

edit flag offensive delete link more
0

answered 2014-01-03 12:04:58 -0500

SamYaple gravatar image

I would suggest using the pop-out console and trying again. I have had a few issues with the integrated console not picking up what I type into it.

An additional question, are you using a non-US, non-standard, or foreign keyboard layout? If so, can you verify what input you are actually receiving (keycoards from the keyboard).

edit flag offensive delete link more

Comments

Thank you, I tried point a browser to a link from nova get-vnc-console <instance> novnc and I got same behavior. My keyboard layout is en-us, the default keyboard. Would you mind to inform how can I get keyboard codes from instance log? Thank you!

eshine gravatar imageeshine ( 2014-01-03 12:48:05 -0500 )edit

I am experiencing the same problem....I cant seem to find a solution.....please share the solution if you have solved this issue.....thanks!

kumar.govind.s gravatar imagekumar.govind.s ( 2014-01-13 22:42:54 -0500 )edit

Make sure you do a mouse press in the outside gray area before you start using the connection. If you don't you will experience this issue in some situations.

SamYaple gravatar imageSamYaple ( 2014-01-14 07:47:32 -0500 )edit

I have tried that, it does not work. I think it may have to do with keyboard layout....I am not able to enter specific characters such as ":" , "}", "?" - for some reason. I am able to enter rest of password "cubswin" and ")" - except ":". The complete password is "cubswin:)", Please share ideas

kumar.govind.s gravatar imagekumar.govind.s ( 2014-01-14 20:35:46 -0500 )edit
0

answered 2015-09-29 03:32:42 -0500

Attila Szlovencsak gravatar image

I had the same problem. I figured out that the locale presented by the browser was different to the locale of my keyboard layout. So when my locale settings was

$ env |grep LC
LC_PAPER=hu_HU.utf8
LC_MONETARY=hu_HU.utf8
LC_NUMERIC=hu_HU.utf8
LC_MEASUREMENT=hu_HU.utf8
LC_TIME=hu_HU.utf8

, the en_US keyboard layout was producing strange letters, however the layout hu_HU was working correctly.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2014-01-03 11:08:09 -0500

Seen: 6,325 times

Last updated: May 15 '17