Ask Your Question
0

Can't Assign Network to VM's

asked 2016-10-25 09:28:43 -0600

Scott MacNeill gravatar image

updated 2016-10-25 11:57:21 -0600

Hey gang, I'll preface this by saying i'm very new to this. I followed the guide on openstack dot org to build a lab here. I have 3 nodes, Controller, Compute, Network. All three nodes have 4 networks attached. 1-management 2-internal traffic (1921.68.1.0/24) 3-external network (10.3.39.0/24) 4-network to be used later for floating / internet ip's.

Attached is a Pic how i think i'm supposed to be building this: i <dot> imgur <dot> com/Pvbl6eA.jpg (sorry it will not let me post links yet)

My Switch config (Same on Compute & Network Node) is as follows:

ovs-vsctl show
67064c7b-5d1a-4a20-98f9-1923728aea12

Bridge br-int
        fail_mode: secure
        Port int-br-ex
            Interface int-br-ex
                type: patch
                options: {peer=int-br-ex}
  Port patch-tun
            Interface patch-tun
                type: patch
                options: {peer=patch-int}
        Port br-int
            Interface br-int
                type: internal
  Bridge br-tun
        fail_mode: secure
        Port "em2"
            Interface "em2"
        Port br-tun
            Interface br-tun
                type: internal
        Port patch-int
            Interface patch-int
                type: patch
                options: {peer=patch-tun}
Bridge br-ex
        Port "p2p2"
            Interface "p2p2"
        Port br-ex
            Interface br-ex
                type: internal
        Port phy-br-ex
            Interface phy-br-ex
                type: patch
                options: {peer=int-br-ex}
    ovs_version: "2.3.2"

When i boot my VM, it does not seem to assign a network to it: i <dot> imgur <dot> com/HV4dw5R.png (sorry, will not let me post links yet)

I'm a little lost on how to gain network connectivity so i can manage these boxes. All attached networks to the hosts are real physical networks configured in a switch.

Am I completely off base on how i built this?

Thanks!

EDIT To add additional Information

Controler ml2_conf.ini

[ml2]
type_drivers = flat,vlan,gre,vxlan
tenant_network_types = gre
mechanism_drivers = openvswitch

[ml2_type_flat]

[ml2_type_vlan]

[ml2_type_gre]
tunnel_id_ranges = 1:1000

[ml2_type_vxlan]

[securitygroup]
enable_security_group = True
enable_ipset = True
firewall_driver = neutron.agent.linux.iptables_firewall.OVSHybridIptablesFirewallDriver

Compute ml2_conf.ini

[ml2]
type_drivers = flat,vlan,gre,vxlan
tenant_network_types = gre
mechanism_drivers = openvswitch

[ml2_type_flat]

[ml2_type_vlan]

[ml2_type_gre]
tunnel_id_ranges = 1:1000

[ml2_type_vxlan]

[securitygroup]
enable_security_group = True
enable_ipset = True
firewall_driver = neutron.agent.linux.iptables_firewall.OVSHybridIptablesFirewallDriver

[ovs]

local_ip = 192.168.184.103

[agent]
tunnel_types = gre

Network ml2_conf.ini

[ml2]
type_drivers = flat,vlan,gre,vxlan
tenant_network_types = gre
mechanism_drivers = openvswitch

[ml2_type_flat]
flat_networks = external

[ml2_type_vlan]

[ml2_type_gre]
tunnel_id_ranges = 1:1000

[ml2_type_vxlan]

[securitygroup]
enable_security_group = True
enable_ipset = True
firewall_driver = neutron.agent.linux.iptables_firewall.OVSHybridIptablesFirewallDriver

[ovs]

local_ip = 192.168.184.103
bridge_mappings = external:br-ex

[agent]
tunnel_types = gre

My Interface info as i've planned for is:

Controller:
MGMT - em1:192.168.184.101
Tunnel - em2 :192.168.1.9
Ext1 - p1p1:Internet Floating   
Ext2 - p1p2:VM-MGMT        

Compute:
MGMT - em1:192.168.184.103               
Tunnel - em2:192.168.1.11                      
Ext1 - p2p1:Internet Access Floating                              
Ext2 - p2p2:VM-MGMT                       

Network:
MGMT - em1:192.168.184.102               
Tunnel - em2:192.168.1.10                      
Ext1 - em3:Internet Access Floating                              
Ext2 - em4:VM-MGMT

Here are my interface ifconfigs:

Controller:

root@controller:/etc/neutron# ifconfig -a
em1       Link encap:Ethernet  HWaddr c4:34:6b:c0:0f:48
          inet addr:192.168.184.101  Bcast:192.168.184.255  Mask:255.255.255.0
          inet6 addr: fe80::c634:6bff:fec0:f48/64 Scope:Link
          UP ...
(more)
edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
1

answered 2016-10-25 11:27:05 -0600

mesutaygun gravatar image

share config file with us. Maybe ı can help you. Especially openswitchagent.ini compute and network nodes And share the ifconfig inf

edit flag offensive delete link more

Comments

I've updated the original Post above with all the info you asked for.

I cant seem to find an openswitchagent.ini file. I assume you might be looking for the /etc/neutron/plugins/ml2/ml2_conf.ini file though? that's what i will attach in my next reply!

Scott MacNeill gravatar imageScott MacNeill ( 2016-10-25 11:58:13 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-10-25 09:28:43 -0600

Seen: 161 times

Last updated: Oct 25 '16