Ask Your Question
0

Mirantis 9 in VMware / Virtualbox deploy fails network test

asked 2016-10-19 17:11:25 -0600

baldpope gravatar image

updated 2016-10-20 14:36:24 -0600

rbowen gravatar image

I'm attempting to deploy Mirantis within VMWare workstation following the instructions for setting up the environment under Virtualbox. With some modifications to the instructions I believe I've got my network set correctly for the host server.

I created a total of 5 VMs, 1 for the Mirantis installation, 1 controller, 2 compute/cinder/ceph nodes, and 1 ironic node. When deploying, the system prompts/warns to configure networking within the cloud infrastructure. Four unique networks are defined

Public - 172.16.0.0/24
Storage - 192.168.1.0/24
Management - 192.168.0.0/24
Baremetal - 192.168.3.0/24

The public network (172.16.0.0/24) is configured as host only network interface (in workstation) and is assigned to each node. This is part of the pre-installation instructions

master - 3 nics ; eth0 - 10.20.0.0/24 ; eth1 172.16.0.0/24 ; eth2 as NAT (public network access)
3 nodes - 3 nics ea; eth0 - 10.20.0.0/24; eth1 172.16.0.0/24 ; eth2 172.16.1.0/24

Following the installation instructions, I believe no other changes were required to the web UI to deploy. When deploying; the installation eventually times out due to failing network connectivity.

The complete error:

Verification failed.

Repo availability verification failed on following nodes controller main.

Following repos are not available - http://archive.ubuntu.com/ubuntu/, http://mirror.fuel-infra.org/mos-repo....

Repo availability verification using public network failed on following nodes controller main.

Following repos are not available - http://archive.ubuntu.com/ubuntu/, http://mirror.fuel-infra.org/mos-repo....

Check your public network settings and availability of the repositories from public network. Please examine nailgun and astute logs for additional details.

As an additional note, this is a fresh install of Mirantis 9.0 updated to 9.1.

I've just reset the deployment, and going to walk through each step again, but wanted to ask - Is anyone else experiencing similar deployment issues?

-balpdope

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2016-12-28 23:41:29 -0600

Chaithanya gravatar image

Your public network is a host only adapter so it cannot reach outside world for internet access. so you need to enable NAT (MASQUERADE) in your master VM. So that your master forwards the packets from the host only interface(Public) to Nat interface in your case in master you need to forward packets from eth1 to eth2.

edit flag offensive delete link more
0

answered 2016-12-27 05:35:03 -0600

kd akane gravatar image

I run into similar issue, in my case the update from Mirantis 9.0 -> 9.1 changed iptables on fuel master VM. After the upgrade to 9.1 I redo step 7. "Enable NAT (MASQUERADE) and IP forwarding for the Public network:" in the install fuel instruction. After that my deployment was successful.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-10-19 16:47:28 -0600

Seen: 532 times

Last updated: Dec 28 '16