Ask Your Question

Swift doesn't connect to controller:8080 [Errno 111] Connection

asked 2016-10-19 00:15:30 -0500

I am deploying multinode openstack:

  • 1 controller node
  • 1 network node
  • 1 compute node
  • 1 cinder node
  • 1 swift node
  • 1 swift proxy node

Stuck on Swift configuration:

swift list

HTTPConnectionPool(host='controller', port=8080): Max retries exceeded with url: /v1/AUTH_cdbcbc3eeb8a472c8abb2b67e749774c?format=json (Caused by : [Errno 111] Connection refused)

Here is a detailed swift configuration on swift storage node , swift proxy node as well as associated keystone swift service and endpoitns:

verified that:

  • All nodes are reachable from each other, but not controller port 8080.
  • Swift services are up on swift and swift proxy

None of the similar questions provides a issue:

edit retag flag offensive close merge delete



Looks like swift-proxy is running on host different from Controller. Endpoint for swift-proxy is wrong.

1, Check where swift-proxy is running. 
2. Check endpoint for swift-proxy.
dbaxps gravatar imagedbaxps ( 2016-10-19 01:37:58 -0500 )edit

Thank you very much dbaxps!
Indeed with a separate deployment of swift proxy node, I should have configured swift endpoint url with swift proxy nodeNOT controller. Now it works fine. (dbaxps, if you copy your comments to an answer I'll mark it as solution)

AJ NOURI gravatar imageAJ NOURI ( 2016-10-19 08:23:38 -0500 )edit

1 answer

Sort by ยป oldest newest most voted

answered 2016-10-19 13:13:36 -0500

dbaxps gravatar image

I guess swift-proxy is not running on Controller , hence endpoint is currently wrong

1, Check where swift-proxy is running. 
2. Check endpoint for swift-proxy.
edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2016-10-19 00:15:30 -0500

Seen: 464 times

Last updated: Oct 19 '16