Upgrade Liberty to Newton, Launch Instance (policy issue?)

asked 2016-10-16 19:07:58 -0500

devinacosta gravatar image

updated 2016-10-18 13:25:23 -0500

rbowen gravatar image

I have been working all weekend on my migration from Mitaka to Newton. I have almost everything working the final issue I think I need to solve is when I go to launch an issue, Neutron gives the instance an IP address but then Nova freaks out about the policy i'm believing.

It complains about failing to notify Nova, however I have validated that i do have what i believe to be the correct settings in my neutron.conf to allow it to work?

2016-10-16 16:37:38.675 58844 ERROR neutron.notifiers.nova [-] Failed to notify nova on events: [{'tag': u'3b3c97ee-a05b-4388-af56-2f9b6379a429', 'name': 'network-vif-deleted', 'server_uuid': u'f92e14db-f356-4702-8fc7-335f4eadf155'}]
2016-10-16 16:37:38.675 58844 ERROR neutron.notifiers.nova     raise exceptions.from_response(resp, method, url)
2016-10-16 16:37:38.675 58844 ERROR neutron.notifiers.nova Unauthorized: The request you have made requires authentication. (HTTP 401) (Request-ID: req-00dd9bc3-264d-4a38-9517-6164ec7fa3cf)
2016-10-16 16:37:38.675 58844 ERROR neutron.notifiers.nova

I copied my old policy.json for Nova into the policy.json for Nova and that didn't fix the issue?

edit retag flag offensive close merge delete

Comments

To me it looks like the problem occurs before Nova gets to authorize the request. It looks like an authentication problem, as if Neutron's credentials are not accepted by Keystone. If you switch on DEBUG logging, you may see the actual API that is refused, which may then confirm my suspicion.

Bernd Bausch gravatar imageBernd Bausch ( 2016-10-17 05:10:56 -0500 )edit

Try "keystone token-get" and see what happens. This should tell you the problem if your credentials are wrong. If they are correct there is some problem configuring keystone with Neutron.

hem gravatar imagehem ( 2016-10-17 11:05:16 -0500 )edit

better to go with new polocy.json ... in nova.conf have a look at 'vif' settings... I would need more details to resolve this issue.. like nova and neutron logs..

omkar_telee gravatar imageomkar_telee ( 2016-10-18 23:34:25 -0500 )edit