Ask Your Question
1

DB update failed during magnum install

asked 2016-10-12 09:07:22 -0500

pcastets gravatar image

I am following this guide: http://docs.openstack.org/project-install-guide/container-infrastructure-management/newton/install-ubuntu.html (http://docs.openstack.org/project-ins...) to install Magnum (Newton) in Ubuntu 16.04.

I have the following error when populating the magnum database:

# su -s /bin/sh -c "magnum-db-manage upgrade" magnum
    ...
      File "/usr/lib/python2.7/dist-packages/oslo_db/sqlalchemy/migration_cli/manager.py", line 47, in __init__
        raise ValueError('There must be at least one plugin active.')
    ValueError: There must be at least one plugin active.

Note: I had previously installed and removed the magnum packages. I had also manually removed the "magnum" database before re-installing the packages.

edit retag flag offensive close merge delete

Comments

Hi~ I've got into the same problem. Have you sloved it?

rogeryu gravatar imagerogeryu ( 2016-10-26 06:06:23 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-11-10 04:36:43 -0500

updated 2016-11-11 10:53:52 -0500

This is the same issue as in https://bugs.launchpad.net/magnum/+bug/1636131.

The fix for this was proposed in https://bugs.launchpad.net/ubuntu/+source/magnum/+bug/1632743 and the fixed python-magnum package has been uploaded as version 3.1.1-1 in the Debian Unstable repository (see https://packages.debian.org/unstable/main/python-magnum ).

I cannot see that Ubuntu has updated this package in their repos yet, however a temporary fix would be to download and install the Debian package from https://packages.debian.org/sid/all/python-magnum/download

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-10-12 05:43:36 -0500

Seen: 316 times

Last updated: Nov 11 '16