Ask Your Question
0

Failed to connect to server (code: 1006)

asked 2016-10-11 15:29:56 -0500

jbdkz100 gravatar image

I have created an OpenStack test environment based on the Martika release using the following instructions:

http://docs.openstack.org/mitaka/inst...

My test environment has both a management and provider networks, here are the IPs of my single Controller and Compute nodes:

controller Management Network 10.0.0.10 Provider Network 192.168.0.2

compute1 Management Network 10.0.0.11 Provider Network 192.168.0.3

I am able to create an instance but get the "Failed to connect to server (code: 1006) when try to connect to the console of my Cirros based instance.

"controller" resolves to 10.0.0.10 and is in the host file of all servers in the test OpenStack environment. Here are the relevant portions of the /etc/nova/nova.conf file from the compute node:

 [DEFAULT]
...
my_ip = 10.0.0.11

[vnc]
...
vncserver_listen = $my_ip
vncserver_proxyclient_address = $my_ip

[glance]
...
api_servers = http://controller:9292
edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2016-10-12 10:11:58 -0500

jbdkz100 gravatar image

Resolved!

my_ip parameter in /ect/nova/nova.conf on controller node was set to the wrong IP address. It was set to the management IP address of the compute node by mistake. I changed it to the management IP address of the controller node and now it is working.

edit flag offensive delete link more
0

answered 2016-10-12 03:12:38 -0500

dbaxps gravatar image

Remove sign "$" in [vnc] section . Nova.conf syntax is different from bash scripting.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-10-11 15:29:56 -0500

Seen: 4,710 times

Last updated: Oct 12 '16