Ask Your Question
1

The current Horizon settings indicate no valid image creation methods are available. Providing an image location and/or uploading from the local file system must be allowed to support image creation

asked 2016-10-11 13:50:52 -0600

bryanb229 gravatar image

Anyone know how to fix this error?

https://github.com/openstack/horizon/blob/master/openstack_dashboard/dashboards/project/images/images/forms.py (https://github.com/openstack/horizon/...)

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
1

answered 2016-10-24 06:19:35 -0600

spectroman gravatar image

correctly fix this problem

https://bugs.launchpad.net/horizon/+bug/1632383 (https://bugs.launchpad.net/horizon/+b...)

edit flag offensive delete link more
1

answered 2016-10-13 09:24:53 -0600

step77it gravatar image

step1: yum remove openstack-dashboard

step2: rm -rf /etc/openstack-dashboard

step3: yum install openstack-dashboard

step4: nano /etc/openstack-dashboard/local_settings

step5: #ALLOWED_HOSTS = ['horizon.example.com', 'localhost']

      ALLOWED_HOSTS = ['*', ]

step6: reboot

edit flag offensive delete link more

Comments

Can confirm that above mentioned procedure resolves the problem.

Blerry gravatar imageBlerry ( 2016-10-13 17:30:22 -0600 )edit

I did the above procedure. It resolved the mentioned problem. However, the "Image Source" can only be the "File", not "Image Location".

Rez7 gravatar imageRez7 ( 2016-10-18 03:18:32 -0600 )edit

This actually works... just "a half". Can't download images via URL with this solution.

KotoriChannn gravatar imageKotoriChannn ( 2016-10-26 01:21:30 -0600 )edit
1

answered 2016-10-18 03:19:38 -0600

Rez7 gravatar image

I did the above procedure. It resolved the mentioned problem. However, the "Image Source" can only be the "File", not "Image Location". Moreover i downloaded a few images and tried to create an image on OpenStack dashboard, and i get the error message:

"TypeError: Cannot read property 'data' of undefined"

Any help, please?

edit flag offensive delete link more

Comments

try cmdline 1.) source /root/keystonerc_admin 2.) openstack image create --disk-format qcow2 --container-format bare --public --os-image-api-version 1 --location https://download.fedoraproject.org/pub/fedora/linux/releases/22/Cloud/x86_64/Images/Fedora-Cloud-Base-22-20150521.x86_64.qcow2 (https://download.fedoraproject.org/pu...) Fedora22

Orbito gravatar imageOrbito ( 2016-11-01 14:10:20 -0600 )edit

I had this same issue.

When I checked horizon_error.log from /var/log/apache2, I saw this message "You are not authorized to complete publicize_image action" so I changed the image sharing visibility from public to private and it solved the problem

flintstone gravatar imageflintstone ( 2016-11-02 03:27:21 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-10-11 13:50:52 -0600

Seen: 3,704 times

Last updated: Oct 24 '16