Ask Your Question
0

[newton] ceilometer-api cgi-bin path

asked 2016-10-11 08:41:22 -0500

asiamaster gravatar image

Hi, I have installed the newton now.

all the services are working well except ceilometer. I referred below link. http://docs.openstack.org/project-install-guide/telemetry/newton/install-base-ubuntu.html (http://docs.openstack.org/project-ins...)

I can't find the source path where I take the cgi file or folder. ("/var/www/cgi-bin/ceilometer/app") WSGIScriptAlias / "/var/www/cgi-bin/ceilometer/app"

Is there anyone who can help me?

Thanks.

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
1

answered 2016-10-12 04:45:13 -0500

yprokule gravatar image

@asiamaster - gnocchi is the default storage backend for ceilometer in Newton.That means all metrics are stored there. I'm not aware of the integration status between horizon/gnocchi.

Though, U can still enable database backend by editing ceilometer.conf and setting meter_dispatcher=database. After services' restart data would be stored in both backends.

No limit value provided, result set will be limited to 100 just indicates that last 100 samples would be returned. This was done intentionally to disallow wildcard queries which were affecting performance.

edit flag offensive delete link more

Comments

Hello, Thanks for answer for me.

I will check it and test it soon.

Anyway I found the root cause and reported it as below. https://bugs.launchpad.net/ubuntu/+source/horizon/+bug/1632606 (https://bugs.launchpad.net/ubuntu/+so...)

Ceilometer can't draw the graph. because js file was corrupted.

Thanks.

asiamaster gravatar imageasiamaster ( 2016-10-12 06:28:03 -0500 )edit
0

answered 2016-10-11 10:02:52 -0500

kirito gravatar image

updated 2016-10-11 22:06:58 -0500

I hava the same error I found this in ceilometer devstack's plugin.sh

sudo cp $CEILOMETER_DIR/ceilometer/api/app.wsgi $CEILOMETER_WSGI_DIR/app

so I do this:

mkdir -p /var/www/cgi-bin/ceilometer
cp /usr/lib/python2.7/site-packages/ceilometer/api/app.wsgi /var/www/cgi-bin/ceilometer/app

It works,you can try this.

edit flag offensive delete link more

Comments

Thanks for the answer.

It works for me. but Stats tab has shown this message "Error: An error occurred. Please try again later. " and doesn't work. and can't draw the graph. (No data available.)

asiamaster gravatar imageasiamaster ( 2016-10-11 10:51:19 -0500 )edit

and this is the error message written the error log when I click the tab. [Tue Oct 11 17:49:57.935892 2016] [wsgi:error] [pid 31406:tid 139792963102464] 2016-10-11 17:49:57.935 31406 INFO ceilometer.api.controllers.v2.utils [-] No limit value provided, result set will be limited to 100.

any idea?

asiamaster gravatar imageasiamaster ( 2016-10-11 10:51:37 -0500 )edit

I have the same problem on CentOS 7

mario.fernandez gravatar imagemario.fernandez ( 2016-10-11 12:56:23 -0500 )edit

I think i should install the gnocchi

kirito gravatar imagekirito ( 2016-10-11 22:23:23 -0500 )edit

I installed python-gnocchi. but the problem is not solved yet.

asiamaster gravatar imageasiamaster ( 2016-10-12 01:23:52 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-10-11 08:41:22 -0500

Seen: 683 times

Last updated: Oct 12 '16