Error during Kilo installation: Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-L_8SF4/positional

asked 2016-10-11 06:31:32 -0500

aamir gravatar image

Am trying to install devstack kilo branch on ubuntu 14.04. I am running ubuntu 14.04 from live usb.

I get the following error. After each failure I have tried a couple of things and then run unstack.sh and clean.sh and tried to reinstall. But nothing works. Please help.

.
.
.
.
ip install --upgrade 'keystonemiddleware>=4.2.0,!=4.5.0'
2016-10-11 10:53:33.956 | Collecting keystonemiddleware!=4.5.0,>=4.2.0
2016-10-11 10:53:34.405 | /usr/local/lib/python2.7/dist-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:90: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. For more information, see https://urllib3.readthedocs.org/en/latest/security.html#insecureplatformwarning.
2016-10-11 10:53:34.405 |   InsecurePlatformWarning
2016-10-11 10:53:35.020 |   Using cached keystonemiddleware-4.10.0-py2.py3-none-any.whl
2016-10-11 10:53:35.044 | Collecting WebOb>=1.2.3 (from keystonemiddleware!=4.5.0,>=4.2.0)
2016-10-11 10:53:35.116 |   Using cached WebOb-1.6.1-py2.py3-none-any.whl
2016-10-11 10:53:35.134 | Collecting oslo.context>=2.9.0 (from keystonemiddleware!=4.5.0,>=4.2.0)
2016-10-11 10:53:35.169 |   Using cached oslo.context-2.9.0-py2.py3-none-any.whl
2016-10-11 10:53:35.188 | Collecting oslo.i18n>=2.1.0 (from keystonemiddleware!=4.5.0,>=4.2.0)
2016-10-11 10:53:35.239 |   Using cached oslo.i18n-3.9.0-py2.py3-none-any.whl
2016-10-11 10:53:35.257 | Collecting oslo.serialization>=1.10.0 (from keystonemiddleware!=4.5.0,>=4.2.0)
2016-10-11 10:53:35.300 |   Using cached oslo.serialization-2.13.0-py2.py3-none-any.whl
2016-10-11 10:53:35.318 | Collecting positional>=1.1.1 (from keystonemiddleware!=4.5.0,>=4.2.0)
2016-10-11 10:53:35.345 |   Using cached positional-1.1.1.tar.gz
2016-10-11 10:53:36.122 |     Complete output from command python setup.py egg_info:
2016-10-11 10:53:36.122 |     install_dir .
2016-10-11 10:53:36.122 |     Traceback (most recent call last):
2016-10-11 10:53:36.122 |       File "<string>", line 20, in <module>
2016-10-11 10:53:36.122 |       File "/tmp/pip-build-L_8SF4/positional/setup.py", line 26, in <module>
2016-10-11 10:53:36.122 |         pbr=True)
2016-10-11 10:53:36.122 |       File "/usr/lib/python2.7/distutils/core.py", line 111, in setup
2016-10-11 10:53:36.122 |         _setup_distribution = dist = klass(attrs)
2016-10-11 10:53:36.122 |       File "/usr/local/lib/python2.7/dist-packages/distribute-0.6.14-py2.7.egg/setuptools/dist.py", line 221, in __init__
2016-10-11 10:53:36.122 |         self.fetch_build_eggs(attrs.pop('setup_requires'))
2016-10-11 10:53:36.122 |       File "/usr/local/lib/python2.7/dist-packages/distribute-0.6.14-py2.7.egg/setuptools/dist.py", line 245, in fetch_build_eggs
2016-10-11 10:53:36.122 |         parse_requirements(requires), installer=self.fetch_build_egg
2016-10-11 10:53:36.122 |       File "/usr/local/lib/python2.7/dist-packages/distribute-0.6.14-py2.7.egg/pkg_resources.py", line 544, in resolve
2016-10-11 10:53:36.122 |         dist = best[req.key] = env.best_match(req, self, installer)
2016-10-11 10 ...
(more)
edit retag flag offensive close merge delete