Ask Your Question
0

RDO install newton in the dashboard can't create images.

asked 2016-10-11 03:18:56 -0600

penn gravatar image

The current Horizon settings indicate no valid image creation methods are available. Providing an image location and/or uploading from the local file system must be allowed to support image creation.

edit retag flag offensive close merge delete

5 answers

Sort by ยป oldest newest most voted
2

answered 2016-10-11 05:57:30 -0600

dbaxps gravatar image

updated 2016-10-11 06:03:42 -0600

That is known issue. Source keystonerc_admin to Controller's shell , download qcow2 image :-

$  glance image-create --name "RHEL-7.2-image" --disk-format qcow2 \
     --container-format bare --progress < rhel-72.qcow2

Update image features via dashboard (admin login) or via glance/openstack CLI as admin.

edit flag offensive delete link more
1

answered 2016-10-26 22:32:07 -0600

zxt50330 gravatar image

/usr/share/openstack-dashboard/openstack_dashboard/local/local_settings.py

REST_API_REQUIRED_SETTINGS = ['OPENSTACK_HYPERVISOR_FEATURES',
                                'LAUNCH_INSTANCE_DEFAULTS',
                                'OPENSTACK_IMAGE_FORMATS']
edit flag offensive delete link more

Comments

This resolved my issue- Restarting the services didn't help- a full reboot did the trick. Cheers.

mmagbee gravatar imagemmagbee ( 2016-11-01 15:57:14 -0600 )edit

This resolved my issue too!

masber gravatar imagemasber ( 2016-11-26 02:49:41 -0600 )edit

this procedure worked for me, after changing this file /etc/openstack-dashboard/local_settings which is the same file showed above and rebooting. thanks you guys :)

Luis Caballero gravatar imageLuis Caballero ( 2016-12-15 16:42:17 -0600 )edit
1

answered 2016-10-24 06:05:08 -0600

frz59 gravatar image

updated 2016-10-24 06:30:39 -0600

Hi there, If you want to enable upload image in Horizon, you need to do some changes in local_settings file

 /usr/share/openstack-dashboard/openstack_dashboard/local/local_settings.py

Add following lines at the end of file:

HORIZON_IMAGES_ALLOW_UPLOAD = True
HORIZON_IMAGES_UPLOAD_MODE = "legacy"
IMAGES_ALLOW_LOCATION = True

Then you should restart httpd service.

systemctl restart httpd.service

horizon panel image upload

edit flag offensive delete link more

Comments

umm... that's not working for me. Do i need to set something more?

KotoriChannn gravatar imageKotoriChannn ( 2016-10-25 23:57:33 -0600 )edit

@kycfeel Do you receive any errors when you set configurations?

frz59 gravatar imagefrz59 ( 2016-10-26 05:47:34 -0600 )edit

Neither did it work for me

yasir.elsharif gravatar imageyasir.elsharif ( 2016-10-26 05:49:56 -0600 )edit
0

answered 2017-03-03 17:19:46 -0600

if this does not work check the perms on your glance upload dir (commonly some form of tmp with 777) and set your glance dir to 774

edit flag offensive delete link more
0

answered 2016-10-24 06:18:29 -0600

spectroman gravatar image

correctly fix the problem.

https://bugs.launchpad.net/horizon/+bug/1632383 (https://bugs.launchpad.net/horizon/+b...)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-10-11 03:18:56 -0600

Seen: 6,456 times

Last updated: Mar 03