Ask Your Question
0

RDO Mikata upgrade bugfix and security update

asked 2016-10-10 14:18:48 -0500

satish.lx gravatar image

I have installed RDO (mikata) version 3 month back but look like in last 3 month they have fixed many bug and security fix. Now how do i upgrade existing mikata with those bug fixes?

Just i just use "yum upgrade" or re-run packstack again with same answerfile like followin?

packstack --answer-file=foo.txt

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
1

answered 2016-10-11 02:23:46 -0500

dbaxps gravatar image

updated 2016-10-12 02:02:59 -0500

UPDATE 10/12/16
Snadard Repos Setup

 $  sudo yum -y install   yum-plugin-priorities 
 $  sudo  curl -o  /etc/yum.repos.d/delorean-mitaka.repo   http://buildlogs.centos.org/centos/7/cloud/x86_64/rdo-trunk-mitaka-tested/delorean.repo
 $  sudo curl -o  /etc/yum.repos.d/delorean-deps-mitaka.repo https://trunk.rdoproject.org/centos7-mitaka/delorean-deps.repo

END UPDATE

"../centos7-mitaka/current-passed-ci" shoud have fixed packages. Details here
https://ask.openstack.org/en/question...

edit flag offensive delete link more

Comments

I follow your method and upgraded openstack using "yum update" and restarted all service but after that my VM not able to ping q-router after spend some time i check there is no gateway IP address on any of qrouter-* all qrouter has only 127.0.0.1 ip address. what is wrong there?

satish.lx gravatar imagesatish.lx ( 2016-10-12 13:38:36 -0500 )edit

nevermind. i have restarted neutron-netns-cleanup.service which clean up all namespace. after restart neutron-dhcp-agent , neutron-l3-agent and neutron-openvswitch-agent fixed issue, thanks

satish.lx gravatar imagesatish.lx ( 2016-10-12 13:50:29 -0500 )edit

I am running RDO in production so is it safe to do that because in document they said use tripleo and i have no idea what is that and why we should use that instead of RDO

satish.lx gravatar imagesatish.lx ( 2016-10-12 13:51:31 -0500 )edit

Sorry, but TripleO Bare Metal is officially approved for prod deployments, even though simple adding new compute node to overcloud is supposed to update heat stack "overcloud" on undercloud. What is a potential risk for overcloud as entity.

dbaxps gravatar imagedbaxps ( 2016-10-12 14:35:20 -0500 )edit
0

answered 2016-10-11 11:22:51 -0500

yum upgrade should be fine. Through running packstack you can install using latest packages on clean nodes.

edit flag offensive delete link more

Comments

Do i need to enable any repo or add repo because if i ran yum upgrade and its throwing lots of erlang dependency as @dbaxps mentioned. I believe we need to enable "buildlogs.centos.org/centos/7/cloud" which is disabled by default and all latest packet i am seeing in that repo.

satish.lx gravatar imagesatish.lx ( 2016-10-11 17:44:06 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-10-10 14:18:48 -0500

Seen: 80 times

Last updated: Oct 12 '16