Ask Your Question
0

How to change the domain name for internal host in openstack?

asked 2016-10-10 07:24:27 -0500

meankit008 gravatar image

When i try to look for my hostname of cic's or compute's it gives output: root@cic-0-1:~# hostname cic-0-1.domain.tld root@compute-0-2:~# hostname compute-0-2.domain.tld or, root@compute-0-2:~# nslookup compute-0-2 Server: 190.108.10.1 Address: 190.108.10.1#53

Name: compute-0-2.domain.tld Address: 190.108.10.130

I don't want "domain.tld" to be there i want something else, lets say "open.tld" i want. Where to do that changes so that this dns_domain name(domain.tld) is changed and reflects as per my choice?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2017-04-18 04:46:01 -0500

fifieldt gravatar image

There was a discussion on the mailing list on this recently, the solution being here:

http://lists.openstack.org/pipermail/...

""" Setting dhcp_domain to an empty string in nova.conf on the Control node. For instance 'dhcp_domain='. An instances name can now be set to a FQDN which will then be passed cloud-init via the metadata server.

Secondly, The Neutron DHCP service sets the default DNS suffix for a NIC to openstacklocal . This causes delays in DNS lookups on external DNS servers, as the wrong domain is used by default. Similarly to the above, this can be resolve by setting 'dhcp_domain=' in the Neutron DHCP config file dhcp_agent.ini. Once this is set and the DHCP service restarted, the "--domain=<domain>" parameter no longer gets set """

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2016-10-10 07:24:27 -0500

Seen: 732 times

Last updated: Apr 18 '17