Ask Your Question
0

The instance launched by openstack autopilot Fails to start Raise network interfaces

asked 2016-10-09 08:40:30 -0500

Ali84 gravatar image

updated 2016-10-24 08:06:01 -0500

I installed openstack Autopilot on physical machines. Now I can launch instances but they seems not to get an ip from any dhcp server so obviously I have no access to them. For example when I launch an instance with Xenial image in its log after going through a lot of lines like this:

...[[0m[0;31m*     [0m] A start job is running for Raise network interfaces...

It declares that Failed to start Raise network interfaces

Also juju status reports that

    neutron-gateway/0:
       workload-status:       
       current: blocked
       message: 'Services not running that should be: neutron dhcp-agent, neutron-vpn-agent'

Running neutron agent-listcommand reveals that many other services are not working probably either.

I tried to manually start "neutron dhcp-agent" on a node where neutron-gateway is placed but got this error

start: Rejected send message, 1 matched rules; type="method_call", sender=":1.9" (uid=1000 pid=99077 comm="start neutron-dhcp-agent ") interface="com.ubuntu.Upstart0_6.Job" member="Start" error name="(unset)" requested_reply="0" destination="com.ubuntu.Upstart" (uid=0 pid=1 comm="/sbin/init ")

Now I'm stranded by this mess not knowing what to do next. Please somebody help me out. Any hint would be greatly appreciated.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-10-24 07:57:13 -0500

Ali84 gravatar image

updated 2016-11-02 10:36:31 -0500

Finally I came across the neutron-ovs-cleanup service log which was error-ridden with

ImportError: cannot import name deploy

Then the quick guide given in this page (https://ask.openstack.org/en/question/11458/keystone-all-importerror-cannot-import-name-deploy/ (https://ask.openstack.org/en/question...)) did the rest. Well it was the incompatible version of this Python library (PasteDeploy) I guess that made the service fail and consequently led to other related networking services failure as well. So I ran pip uninstall --yes PasteDeploy && pip install 'PasteDeploy>=1.5.0' as instructed on the page above and all of a sudden it worked :-)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2016-10-09 08:40:30 -0500

Seen: 1,702 times

Last updated: Nov 02 '16