Mitaka: Instance cannot be allocated IP address

asked 2016-10-09 00:05:27 -0600

Chris Liu gravatar image

Hi there,

I'm a new in OpenStack, I follow the installation guide to setup Mitaka with Ubuntu 14.04: (

I created two vmware VMs for my POC, controller and compute, and allocated two NICs for each VM. I have two subnets for management network and provider network, they are and I choose provider network for my installation.

My vmware VM does not support KVM, so I'm using "qemu" for virtual type. Everything went well when I installed, finally I launched a instance on my openstack, and there was a IP address was assigned to this instance.

| ID                                   | Name | Status | Networks            |
| 9f0a40d9-3513-4620-acba-a24e2734cf7d | 111  | ACTIVE | provider= |

But I cannot access this instance with this IP address(ping and ssh), I tried to search for the problem on google, and find many people got the same issue what instances cannot get IP from DHCP server, I tried their solutions on my environment, no one worked. I don't know what's wrong with my installation, I just follow the guide with nothing different. Please help me! Thanks very much.

Starting log for my instance on openstack:

info: initramfs: up at 4.13
GROWROOT: CHANGED: partition=1 start=16065 old: size=64260 end=80325 new: size=2072385,end=2088450
info: initramfs loading root from /dev/vda1
info: /etc/init.d/rc.sysinit: up at 5.75
info: container: none
Starting logging: OK
modprobe: module virtio_blk not found in modules.dep
modprobe: module virtio_net not found in modules.dep
WARN: /etc/rc3.d/S10-load-modules failed
Initializing random number generator... done.
Starting acpid: OK
cirros-ds 'local' up at 7.84
no results found for mode=local. up 8.30. searched: nocloud configdrive ec2
Starting network...
udhcpc (v1.20.1) started
Sending discover...
Sending discover...
Sending discover...
Usage: /sbin/cirros-dhcpc <up|down>
No lease, failing
WARN: /etc/rc3.d/S40-network failed
cirros-ds 'net' up at 189.60
failed 1/20: up 189.94. request failed
failed 2/20: up 192.27. request failed
failed 3/20: up 194.51. request failed
failed 4/20: up 196.76. request failed
failed 5/20: up 199.01. request failed
failed 6/20: up 201.25. request failed
failed 7/20: up 203.55. request failed
failed 8/20: up 205.84. request failed
failed 9/20: up 208.14. request failed
failed 10/20: up 210.45. request failed
failed 11/20: up 212.72. request failed
failed 12/20: up 214.99. request failed
failed 13/20: up 217.40. request failed
failed 14/20: up 219.60. request failed
failed 15/20: up 221.79. request failed
failed 16/20: up 223.99. request failed
failed 17/20: up 226.19. request failed
failed 18/20: up 228.40. request failed
failed 19/20: up 230.61. request failed ...
edit retag flag offensive close merge delete


If you login to your VM via the console, does configuring the IP manually work? If so, then you should just be able to use a config drive to pass information to your VM (the '--config-drive True') option.

tedlit gravatar imagetedlit ( 2016-10-09 21:08:23 -0600 )edit

I did that before, but it didn't work. I saw other people posted the "ifconfig" information for compute node, the virtual interface is supposed to be allocated a IP address, but I cannot see that for my compute node.

Chris Liu gravatar imageChris Liu ( 2016-10-10 11:54:12 -0600 )edit

Have same problem on 3x LAB on VMware based on ESXi. Tryed with Ubuntu 16.04 + newton. CentOS7 with Mitaka. Ubuntu 14.04 + Mitaka. Weird is that when used official tutorial ( and used Physical Machines DHCP works fine... Maybe its VMware error.

sztyrlic111 gravatar imagesztyrlic111 ( 2016-10-11 13:37:20 -0600 )edit

2 answers

Sort by ยป oldest newest most voted

answered 2016-10-13 14:17:21 -0600

Jonathan gravatar image

By default, ESX virtual switches do not allow promiscuous mode, so even though you are enabling it on the interface within the vms, they will still only see packets intended for their MAC address. See "Configuring promiscuous mode on a virtual switch or portgroup (1004099)" in the VMware Knowledge Base for details on enabling promiscuous mode on a virtual switch.

edit flag offensive delete link more


Thanks, Jo. I tried turn on promiscuous mode on my exsi server, and it works.

Chris Liu gravatar imageChris Liu ( 2016-10-14 12:26:18 -0600 )edit

answered 2016-10-10 11:59:30 -0600

Chris Liu gravatar image

I tried to configure the provider network interface(eth1) into promiscuous mode on controller and compute nodes:

# ifdown eth1
# ifconfig eth promisc
# ifup eth1

root@compute:~# netstat -i

Kernel Interface table
brqf32b9bcb-f6  1500 0   1194771      0   6780 0             8      0      0      0 BMRU
eth0       1500 0   2675318      0   2092 0        653184      0      0      0 BMRU
eth1       1500 0   1194827      0     11 0            35      0      0      0 BMRU
lo        65536 0   1699417      0      0 0       1699417      0      0      0 LRU
tap880d7945-0d  1500 0         9      0      0 0        134390      0      0      0 BMRU
virbr0     1500 0         0      0      0 0             0      0      0      0 BMU

Then, deleted the network and subnet on openstack and launched a new instance. Did not work.

edit flag offensive delete link more

Comments ( - works on physical servers but dont work at VMware vSphere Environment based on ESXi. Have no idea whats goin on :/ Promisc mode + mac change + forged transmits - ALL ACCEPT on distributed switches...

sztyrlic111 gravatar imagesztyrlic111 ( 2016-10-11 13:40:02 -0600 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2016-10-09 00:05:27 -0600

Seen: 765 times

Last updated: Oct 13 '16