Ask Your Question
0

"Error:Invalid service catalog service: image" and "Error: Unable to retrieve image list"

asked 2016-09-29 14:45:13 -0500

Oshan gravatar image

Hello Everyone!

I have configured up to block storage in CentOS by following the OpenStack official documentation(Mitaka) and re-checked the configurations three times. For the installation of neutron i have used Option 1 "Provider Networks".

My problem is :- In the Horizon Dashboard i'am getting the following two errors when trying to create image.

  • "Error: Invalid service catalog service: image"
  • "Error: Unable to retrieve image** list"

Also the "cirros-0.3.4-x86_64-disk" image that uploaded in the initial configuration through the CLI also not showing in the dashboard.

So please give me a idea and information of fixing this error.

Thanks....

Here is my related information.

Log : /var/log/glance/api.log

2016-09-28 19:29:09.305 1264 INFO glance.common.wsgi [-] Removed dead child 2942
2016-09-28 19:33:42.140 1259 INFO glance.common.wsgi [-] Starting 1 workers
2016-09-28 19:33:42.379 2934 INFO eventlet.wsgi.server [-] (2934) wsgi starting up on http://0.0.0.0:9292/
2016-09-28 19:33:42.346 1259 INFO glance.common.wsgi [-] Started child 2934
2016-09-28 20:05:47.564 1259 INFO glance.common.wsgi [-] Removed dead child 2934
2016-09-28 20:05:47.570 1259 INFO glance.common.wsgi [-] Started child 3979
2016-09-28 20:05:47.740 3979 INFO eventlet.wsgi.server [-] (3979) wsgi starting up on http://0.0.0.0:9292/
2016-09-28 20:05:47.741 3979 INFO eventlet.wsgi.server [-] (3979) wsgi exited, is_accepting=True
2016-09-28 20:05:47.741 3979 INFO glance.common.wsgi [-] Child 3979 exiting normally
2016-09-28 20:08:47.968 1268 INFO glance.common.wsgi [-] Starting 1 workers
2016-09-28 20:08:48.010 1268 INFO glance.common.wsgi [-] Started child 2940
2016-09-28 20:08:48.049 2940 INFO eventlet.wsgi.server [-] (2940) wsgi starting up on http://0.0.0.0:9292/
2016-09-28 20:27:40.857 1268 INFO glance.common.wsgi [-] Removed dead child 2940
2016-09-28 20:27:40.862 1268 INFO glance.common.wsgi [-] Started child 3522
2016-09-28 20:27:41.025 3522 INFO eventlet.wsgi.server [-] (3522) wsgi starting up on http://0.0.0.0:9292/
2016-09-28 20:27:41.026 3522 INFO eventlet.wsgi.server [-] (3522) wsgi exited, is_accepting=True
2016-09-28 20:27:41.027 3522 INFO glance.common.wsgi [-] Child 3522 exiting normally
2016-09-29 07:18:35.045 1240 INFO glance.common.wsgi [-] Starting 1 workers
2016-09-29 07:18:35.253 2940 INFO eventlet.wsgi.server [-] (2940) wsgi starting up on http://0.0.0.0:9292/
2016-09-29 07:18:35.272 1240 INFO glance.common.wsgi [-] Started child 2940
2016-09-29 07:44:53.820 2940 INFO eventlet.wsgi.server [req-48a2ddde-b882-402e-b8b5-450b24cc6258 85b82a1f4e2a469fb2587e278ce04d98 51b468cd6d0049598121f19524b8b34a - - -] 192.168.100.151 - - [29/Sep/2016 07:44:53] "GET /v2/images?limit=20&sort_key=name&sort_dir=asc HTTP/1.1" 200 903 0.650037
2016-09-29 07:44:53.827 2940 INFO eventlet.wsgi.server [req-0ec3aa14-9d78-495c-acbb-36645e376f09 85b82a1f4e2a469fb2587e278ce04d98 51b468cd6d0049598121f19524b8b34a - - -] 192.168.100.151 - - [29/Sep/2016 07:44:53] "GET /v2/schemas/image HTTP/1.1" 200 4344 0.002655
2016-09-29 10:06:39.593 1246 ...
(more)
edit retag flag offensive close merge delete

Comments

Can you list the image from the command line using non-admin credentials? If not, then as admin show the output from openstack image show cirros

barry.davis gravatar imagebarry.davis ( 2016-09-30 18:52:02 -0500 )edit
1

Thanks for the comment barry.davis. The problem is solved.

Oshan gravatar imageOshan ( 2016-10-02 13:50:34 -0500 )edit

Hi Oshan, I am facing similar problem in Ubuntu. Can you please let me know how you solved the problem?

sajavadi gravatar imagesajavadi ( 2016-11-15 07:57:56 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
1

answered 2017-04-27 05:33:05 -0500

farooq gravatar image

Recently I encountered the same problem, after removing duplicate glance entries from openstack service list the problem has resolved.

edit flag offensive delete link more
0

answered 2017-02-15 10:49:18 -0500

Jackbmg gravatar image

updated 2017-02-15 10:52:37 -0500

my previous response: who asks a question, finds a solution themselves, and then doesn't post the answer? This is rude.

my new response with an answer: In my case, I had registered the endpoints twice. This was seen when I issued an openstack service list. I had done the openstack service create --name glance.... twice So, I deleted it with "openstack service delete {id} where {id} was found via the openstack service list

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-09-29 07:00:58 -0500

Seen: 1,958 times

Last updated: Apr 27 '17