Ask Your Question
1

Add security rules failed due to multiple security groups named with "default"

asked 2016-09-26 03:55:03 -0500

Sayalic gravatar image

After installed devstack, I follow the http://docs.openstack.org/developer/devstack/networking.html#defaults (doc) to set security rules:

$ openstack security group rule create --proto icmp --dst-port 0 default
More than one security_group exists with the name 'default'.

It claims I have multiple security_group which named with default, but I check with nova secgroup-list:

$ nova secgroup-list
WARNING: Command secgroup-list is deprecated and will be removed after Nova 15.0.0 is released. Use python-neutronclient or python-openstackclient instead.
+--------------------------------------+---------+------------------------+
| Id                                   | Name    | Description            |
+--------------------------------------+---------+------------------------+
| e5466481-f656-46fa-ac72-56f7ab118c70 | default | Default security group |
+--------------------------------------+---------+------------------------+

So, there is only one security group named with default...

Could any one give me some suggestion about that?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-11-22 20:47:23 -0500

maybe you're using admin credentials. my environment is different from yours, but i met the same error. sourcing the demo credentials worked for me.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-09-26 03:55:03 -0500

Seen: 2,020 times

Last updated: Sep 26 '16