Ask Your Question
0

Magnum create bay failed

asked 2016-09-22 01:46:43 -0500

JackLin gravatar image

updated 2016-09-22 14:12:14 -0500

rbowen gravatar image

Hi I am using openstack mitaka, and have followed the official doc to install magnum (version 2.0.0). After creating baymodel successfully, I got the error when create the bay.

Here is the debug information

http://imgur.com/mJjq3Wm

Here is the baymodel

http://imgur.com/uVIjDf2

And my network

http://imgur.com/qisJQPp

Does anyone get the same error as me?

Thanks a lot

edit retag flag offensive close merge delete

Comments

Could you paste the logs of magnum-api and magnum-conductor?

hongbin034 gravatar imagehongbin034 ( 2016-09-23 09:08:15 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2016-09-26 04:01:44 -0500

JackLin gravatar image

Hi! I have solved the problem.

The error was not in the magnum or heat, but in the mariaDB which openstack uses. The default maximum connection is too low that when too many services try to connect the database, it will raise the "too many connection" error and make api of nova, neutron...etc failed. This made my openstack so unstable and errors like HTTPInternalServerError appeared.

What I did was just changed the mariadb maximum connection in the configuration file and restarted it and all works fine now.

Below is the reference I found on google about how to solve the problem http://blog.csdn.net/hnhuangyiyang/article/details/51132141 (http://blog.csdn.net/hnhuangyiyang/ar...)

edit flag offensive delete link more
0

answered 2016-09-23 01:48:52 -0500

Praveen N gravatar image
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-09-22 01:46:43 -0500

Seen: 168 times

Last updated: Sep 26 '16