Ask Your Question
0

Nova-compute does not show up in service list

asked 2016-09-20 22:08:59 -0500

steinm88299 gravatar image

Trying to install Mitaka. Controller node installation went fine. Trying to install compute node on a separate host. When I run 'openstack compute service list' the compute node does not show up. Only the consoleauth, scheduler, and conductor running on the controller are listed. Checked /var/log/nova/nova-compute.log. The RabbitMQ connectivity issues stopped being generated. Am able to ping the controller by name from the compute node and vice versa. Kind of stuck at this point. Host files are populated AND DNS is also configured so I don't think this is name resolution.

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
1

answered 2016-09-21 03:06:40 -0500

hkominos gravatar image

This is 99% because there is some connectivity issue between the Message queue and the compute node.

If you are using RabbitMQ there is a mananagement-plugin that you can install and I think it might help. You can view Which services are connected to a message queue . I suggest install and check if The message queue sees the compute node.

Then we can troubleshot in other places.

edit flag offensive delete link more

Comments

Thanks for the tip. So I did a 'rabbitmqctl list_connections' and do not see a connection from my nova host (192.168.0.30). I am able to telnet from 192.168.0.30 to the controller (192.168.0.20) on 5672. I am also able to ping by name and IP. What can I do next as the Nova logs show nothing wrong.

steinm88299 gravatar imagesteinm88299 ( 2016-09-21 13:38:38 -0500 )edit

So I moved the RabbitMQ stuff to the [default] section from [oslo_messaging]. Now I see 192.168.0.30 in a 'rabbitmqctl list_connections" but still no Nova in the 'openstack compute service list'. The RabbitmQ log file on the controller shows "connection_closed_abruptly" from Nova to controller

steinm88299 gravatar imagesteinm88299 ( 2016-09-21 13:57:22 -0500 )edit

I assume xx.0.30 is your compute node and xx.0.20 is your controller where your message queue is also hosted? Please confirm if your other components are installed . 1)OVS (or linux bridge agent) 2)paste your nova.conf somewhere 3)Tell us more about your environment. Is it FUEL?

hkominos gravatar imagehkominos ( 2016-09-23 02:51:36 -0500 )edit
0

answered 2016-09-21 07:33:36 -0500

Sudhin gravatar image

Hi,

I also had this same issue and i fixed it.

Go to /etc/nova/nova.conf and change my_ip to your management ip. Then change the ownership of nova.conf file to nova nova

edit flag offensive delete link more

Comments

The my_ip was already hardcoded to the Management IP. Ownership was also correct. Thanks for trying to help though. :-)

steinm88299 gravatar imagesteinm88299 ( 2016-09-21 13:30:13 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-09-20 22:08:59 -0500

Seen: 1,695 times

Last updated: Sep 21 '16