neutron network cannot be seen by nova

asked 2014-01-01 16:03:25 -0500

Yuanzhen Gu gravatar image

updated 2014-01-03 17:43:46 -0500

smaffulli gravatar image

I use neutron created newwork, and with #neutron net-list can see it, however, with #nova-manage network list, shows there is no network. and if I use nova boot an instance with command # nova boot --flavor 1 --image <id> --nic <net-id> --tenant <id> vm1, I get as a reply resource could not be found (HTTP 404). I didn't use nova network, I use neutron network, OVS plugin, and have br-int, br-ex.

I have subnet associate to net, and everything can be seen under neutron. Any idea for let nova see neutron network? Am I missing something in nova.conf ?

edit retag flag offensive close delete

Comments

Did you create the subnet and associated the sub-net to net ? As long as it is visible under neutron command you should be fine. Can you tell me the exact command you are running to create the instance ? This will help people to help you.

dheeru ( 2014-01-02 00:11:30 -0500 )edit

Did you check that ? This does not have any effect on the way things work. Are you seeing any issue here ?

dheeru ( 2014-01-02 08:08:27 -0500 )edit

Thanks very much! yes, I have subnet associate to net, and everything can be seen under neutron, and I boot instance #nova boot --flavor 1 --image <id> --nic <net-id> --tenant <id> vm1. I should have pasted it before, I've changed it back to nova network now. I used to let it work with quantum, should similar, I'll try it later, I guess somewhere relative to tell nova neutron will handle the network config.

Yuanzhen Gu ( 2014-01-02 22:26:59 -0500 )edit

Shall Close this request ? Please do let me know.

dheeru ( 2014-01-02 23:28:13 -0500 )edit