Ask Your Question

devstack Heat -DNS resolution not working from instance, cloud-init fails [closed]

asked 2014-01-01 07:56:31 -0500

ramishra gravatar image

updated 2014-01-03 17:40:18 -0500

smaffulli gravatar image

I have devstack on f20 with neutron and heat enabled and trying to deploy Heat wordpress template.

[stack@devstack-rabi devstack]#heat create teststack --template-file=/opt/stack/heat/heat/tests/templates/WordPress_Single_Instance.template --parameters="InstanceType=m1.small;DBUsername=wp;DBPassword=verybadpassword;KeyName=heat_key;LinuxDistribution=F17"

[stack@devstack-rabi devstack]$ heat list
| id                                   | stack_name | stack_status    | creation_time        |
| 5ee7c2a5-5c19-4811-84f6-4348394d6e1f | teststack  | CREATE_COMPLETE | 2014-01-01T11:26:55Z |

However, heat scripts fail to install http and mysql on the f17 instance as DNS resolution not working. Tried to ping external world. Can ping the external ips but not fqdn.

Captured TCP dump for the tap device/port for the instance and it seems the request is refused by dnsmsq as below. Any help to resolve this would be appreciated.

[stack@devstack-rabi devstack]$ sudo tcpdump -i tap2404d0f1-25 -n -v udp port 53
tcpdump: WARNING: tap2404d0f1-25: no IPv4 address assigned
tcpdump: listening on tap2404d0f1-25, link-type EN10MB (Ethernet), capture size 65535 bytes
18:43:13.235378 IP (tos 0x0, ttl 64, id 24109, offset 0, flags [DF], proto UDP (17), length 60) > 2+ A? (32)
18:43:13.235936 IP (tos 0x0, ttl 64, id 61720, offset 0, flags [DF], proto UDP (17), length 60) > 2 Refused 0/0/0 (32)
18:43:13.236389 IP (tos 0x0, ttl 64, id 24109, offset 0, flags [DF], proto UDP (17), length 60) > 3+ A? (32)
18:43:13.236433 IP (tos 0x0, ttl 64, id 61721, offset 0, flags [DF], proto UDP (17), length 60) > 3 Refused 0/0/0 (32)
18:43:13.236800 IP (tos 0x0, ttl 64, id 24109, offset 0, flags [DF], proto UDP (17), length 60) > 4+ A? (32)
18:43:13.236844 IP (tos 0x0, ttl 64, id 61722, offset 0, flags [DF], proto UDP (17), length 60) > 4 Refused 0/0/0 (32)
edit retag flag offensive reopen merge delete

Closed for the following reason too localized by dheeru
close date 2014-01-30 01:31:23.090693


What is the name server specified in resolv.conf ? When you say FQDN is failing, is it for only internal hosts or even external hosts. I feel this issue is nothing to do with openstack.

dheeru gravatar imagedheeru ( 2014-01-04 07:14:35 -0500 )edit

It's there in the pasted tcpdump (instance- , dnsmsq/dns server for the subnet- . resolv.conf has nameserver (dnsmasq) and its expected to use the the host to resolve to the external world.

ramishra gravatar imageramishra ( 2014-01-05 09:12:45 -0500 )edit

You should edit the question to add more details and make it more complete: this site is not like a forum, it's a place where people can find answers to specific problems.

smaffulli gravatar imagesmaffulli ( 2014-01-09 17:45:14 -0500 )edit

1 answer

Sort by ยป oldest newest most voted

answered 2014-01-29 04:18:17 -0500

ramishra gravatar image

I did manage to move ahead this by adding my public dns servers to the public and private networks.

#neutron subnet-update <subnet> --dns_nameservers list=true x.x.x.x,y.y.y.y

It's also possible to make it work by using "dnsmasq_dns_server" parameter in "dhcp_agent.ini"

I also noticed that neutron-dhcp-agent is started with --no-resolv. I suspect that's the reason it's not using the host dns servers.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2014-01-01 07:56:31 -0500

Seen: 2,393 times

Last updated: Jan 29 '14