Ask Your Question
0

can not ping internet when launch instance cirros on mitaka

asked 2016-09-16 14:20:08 -0500

vuhiep gravatar image

updated 2016-09-19 09:02:16 -0500

rbowen gravatar image

I'm new to openstack, I follow eveything in this manual: http://docs.openstack.org/mitaka/inst... and I install on 2 node (controller - compute), choose option 2 (Self-service networks) . After install I can create public network, private network, router - launch instance . I had edited rule for security group, but I can not ping from cirros instance to internet . This is error when I ping router gateway from controller node:

[root@controller ~]# ping 192.168.77.42
PING 192.168.77.42 (192.168.77.42) 56(84) bytes of data.
From 192.168.77.21 icmp_seq=1 Destination Host Unreachable
From 192.168.77.21 icmp_seq=2 Destination Host Unreachable
From 192.168.77.21 icmp_seq=3 Destination Host Unreachable
From 192.168.77.21 icmp_seq=4 Destination Host Unreachable

please tell me what i missing when install mitaka. I think problem bettwen router and public gateway. thanks you.

edit retag flag offensive close merge delete

Comments

1

Please tell me your network configuration and ovs-vsctl details. The interface details for your public interface

Chaithanya gravatar imageChaithanya ( 2016-09-19 00:33:35 -0500 )edit

If you are on mitaka/centos7:

source your keystonerc_admin file and try an openstack-status and paste this please.

   . /root/keystonerc_admin
    openstack-status
    openstack security group list

Did you try pinging from the instance outward? ifconfig / ip r from the console?

bcollins gravatar imagebcollins ( 2016-09-19 09:07:17 -0500 )edit

Not to beat a dead horse but this link has helped me debug a few times.... https://www.rdoproject.org/networking...

my common mistake was attaching to the bridge instead of the name defined in the provider:bridge config.

bcollins gravatar imagebcollins ( 2016-09-19 14:16:59 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2016-10-18 16:48:31 -0500

aegiacometti gravatar image

I'am having a similar issue here. Iam using linuxBridge, and after doing a lot of research, i have found the ARP requests from a VM goes all the way, but the replies, only get to the BRIDGE-Intf, and it is not forwarded to the TAP-Intf.

My configuration is a copy of the current openstack install guides for self-provided networks.

Just a couple of minutes ago, i found a way to make it work, depite it works... doesn't sound like the right way to do it.

Setting the bridgeIntf aging time to cero. "brctl setageing bridgeIntf 0"

As i read, this configuration change could force to forward all the traffic to all the interfaces in the bridge.

any idea?

regards

edit flag offensive delete link more

Comments

i'am running OS inside VMware VMs. I solved the problem using only 1 NIC in the vSwitch. This is because the vSwitch in promiscuos mode route out broadcast in one NIC, and go IN in the other NIC, this cause the OS bridge to learn a MAC on a wrong interface, then the reply get lost

aegiacometti gravatar imageaegiacometti ( 2016-10-23 17:21:18 -0500 )edit
0

answered 2016-10-11 11:27:44 -0500

Without showing your network configuration is quite difficult to understand why you can't ping.

But seen the error message you're reporting seems that you connected your VM to a network that is not available to the hypervisor node. If your vm is connected directly to an external network, please check that the required network is available to the node.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-09-16 14:20:08 -0500

Seen: 466 times

Last updated: Oct 11 '16