Ask Your Question
1

Launchin instance on version 2.3.0 with Linuxbridging failed

asked 2016-09-15 08:56:12 -0600

Matt303 gravatar image

Hello @ll,

since three weeks I follow the Openstack Guide for Debian Jessie several times , I could verify all components besides of launching an instance. I would be happy for any help and hint.

Following commando fails in this section of the guide in http://docs.openstack.org/draft/install-guide-debian/launch-instance-provider.html (http://docs.openstack.org/draft/insta...) :

openstack server create --flavor m1.tiny --image cirros \
  --nic net-id=6a3159e1-5f41-4d5f-9da0-befb214657f6 --security-group default \
  --key-name mykey provider-instance

While following command provides me the net-id

openstack network list
 ID-Column: 6a3159e1-5f41-4d5f-9da0-befb214657f6

I got following Controller's neutron-server.log ("Failed to bind port" in the ERROR line):

2016-09-15 12:48:16.360 17982 DEBUG oslo_messaging._drivers.amqpdriver [req-4f91af10-09dd-4ea3-a997-593593d009e7 d69bdb9aeb7348f8bc724af491528f85 0cf8cc992d124b5e889f887cad975259 - - -] CAST unique_id: 3679d71f240d4533aee73e996f8cbf46 FANOUT topic 'q-agent-notifier-security_group-update' _send /usr/lib/python2.7/dist-packages/oslo_messaging/_drivers/amqpdriver.py:443
2016-09-15 12:48:16.371 17982 DEBUG neutron.plugins.ml2.managers [req-4f91af10-09dd-4ea3-a997-593593d009e7 d69bdb9aeb7348f8bc724af491528f85 0cf8cc992d124b5e889f887cad975259 - - -] Attempting to bind port 96fd72e7-764d-4155-9d21-218094394cf2 on host compute1 for vnic_type normal with profile  bind_port /usr/lib/python2.7/dist-packages/neutron/plugins/ml2/managers.py:685
2016-09-15 12:48:16.372 17982 DEBUG neutron.plugins.ml2.managers [req-4f91af10-09dd-4ea3-a997-593593d009e7 d69bdb9aeb7348f8bc724af491528f85 0cf8cc992d124b5e889f887cad975259 - - -] Attempting to bind port 96fd72e7-764d-4155-9d21-218094394cf2 on host compute1 at level 0 using segments [{'segmentation_id': None, 'physical_network': u'provider', 'id': u'75147951-cc61-4acb-a69a-359fdbcc3b79', 'network_type': u'flat'}] _bind_port_level /usr/lib/python2.7/dist-packages/neutron/plugins/ml2/managers.py:706
2016-09-15 12:48:16.372 17982 ERROR neutron.plugins.ml2.managers [req-4f91af10-09dd-4ea3-a997-593593d009e7 d69bdb9aeb7348f8bc724af491528f85 0cf8cc992d124b5e889f887cad975259 - - -] Failed to bind port 96fd72e7-764d-4155-9d21-218094394cf2 on host compute1 for vnic_type normal using segments [{'segmentation_id': None, 'physical_network': u'provider', 'id': u'75147951-cc61-4acb-a69a-359fdbcc3b79', 'network_type': u'flat'}]

Now some information and configuration files of the setup. Hoping it's not too much.

Openstack Version:

 openstack 2.3.0 (Newton?)

OS:

Debian 8 Jessie Backports

Network Type:

 Neutron Linux Bridging (ml2, no openvswitch)

Hypervisor:

 KVM

Environment:

Controller, Compute1

Controller's neutron.conf

[DEFAULT]
debug = True
auth_strategy = keystone
core_plugin = ml2
service_plugins =
allow_overlapping_ips = True
notify_nova_on_port_status_changes = True 
notify_nova_on_port_data_changes = True
rpc_backend = rabbit
[agent]
root_helper = sudo neutron-rootwrap /etc/neutron/rootwrap.conf
[cors]
[cors.subdomain]
[database]
connection = mysql+pymysql://neutron:PASSWORD@controller/neutron
[keystone_authtoken]
auth_uri = http://controller:5000
auth_url = http://controller:35357
memcached_servers = controller:11211
auth_type = password
project_domain_name = default
user_domain_name = default
project_name = service
username = neutron
password = PASSWORD
[matchmaker_redis]
[nova]
auth_url = http://controller:35357
auth_type = password
project_domain_name = default
user_domain_name = default
region_name = RegionOne
project_name = service
username = nova
password = PASSWORD
[oslo_concurrency]
lock_path = /var/lock/neutron
[oslo_messaging_amqp]
[oslo_messaging_notifications]
[oslo_messaging_rabbit]
rabbit_host = controller
rabbit_userid = openstack
rabbit_password = PASSWORD
[oslo_policy]
[quotas]
[ssl]

Controller's nova.conf

[DEFAULT]
enabled_apis = osapi_compute,metadata
my_ip = 10.0.0.204
pybasedir = /usr/lib/python2.7/dist-packages
state_path = /var/lib/nova
use_neutron = True
firewall_driver = nova.virt.firewall.NoopFirewallDriver
network_api_class = nova.network.neutronv2.api.API
default_floating_pool = ext-nat
linuxnet_interface_driver = nova.network.linux_net.LinuxOVSInterfaceDriver
security_group_api = neutron
rpc_backend = rabbit
auth_strategy = keystone
[api_database]
connection = mysql+pymysql://nova:PASSWORD@controller/nova_api
[barbican]
[cells]
[cinder]
[conductor]
[cors]
[cors.subdomain]
[database]
connection = mysql+pymysql://nova:PASSWORD@controller/nova
[ephemeral_storage_encryption]
[glance]
api_servers = http://controller:9292
[guestfs]
[hyperv]
[image_file_url]
[ironic]
[keymgr]
[keystone_authtoken]
auth_uri = http://controller:5000
auth_url = http://controller:35357
memcached_servers = controller:11211
auth_type = password
project_domain_name = default
user_domain_name = default
project_name ...
(more)
edit retag flag offensive close merge delete

Comments

don't see your ml2_conf.ini http://docs.openstack.org/draft/insta.... Also check the linuxbridge agent logs on the compute

darragh-oreilly gravatar imagedarragh-oreilly ( 2016-09-15 12:44:10 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
1

answered 2016-09-16 04:03:53 -0600

Matt303 gravatar image

updated 2016-09-16 05:07:37 -0600

As requested...

Controller's ml2_conf.ini:

[DEFAULT]
[ml2]
type_drivers = flat,vlan
mechanism_drivers = linuxbridge
extension_drivers = port_security
[ml2_type_flat]
flat_networks = provider
[ml2_type_geneve]
[ml2_type_gre]
tunnel_id_ranges = 1:1000
[ml2_type_vlan]
[ml2_type_vxlan]
[securitygroup]
enable_security_group = True
enable_ipset = True

Coincidently I found another strange behaviour in controller's nova-api.log. It could not found the image:

2016-09-16 10:39:31.504 24666 INFO nova.api.openstack.wsgi [req-ed1a4af9-579a-483c-b499-2804410d2232 946e284be6374bf6a28f2b33e2083de7 741278786d82470f8bcfb57dfce5b3da - - -] HTTP exception thrown: Image not found.

I listed the image file like that:

. demo-openrc

and..

openstack image list

Give me ...

ID: 21eab172-c92d-467e-9591-f311d003d86e
Name: cirros

So I created/launch the instance:

openstack server create --flavor m1.tiny --image cirros   --nic net-id=6a3159e1-5f41-4d5f-9da0-befb214657f6 --security-group default   --key-name mykey provider-instance

The --image cirros is important here.

if I use the ID 21eab172-c92d-467e-9591-f311d003d86e instead of name cirros, this HTTP exception thrown: Image not found does not appear in controller's nova-api.log

That's the command launching with image's ID:

openstack server create --flavor m1.tiny --image 21eab172-c92d-467e-9591-f311d003d86e   --nic net-id=6a3159e1-5f41-4d5f-9da0-befb214657f6 --security-group default   --key-name mykey provider-instance

I had also some issue with neutron but to my opinion I should concentrate on nova-api's issues first...

EDIT:

Concentrating on controller's nova-api.log does not make it work.

Now I see a working instance and I now I will provide some information

Controller's ml2_conf.ini need this in the [ml2]-section:

tenant_network_types =

And I needed to edit /etc/init.d/neutron-server

The documentation provides information to start services like this:

 service neutron-server restart

But only this commando ...

 /etc/init.d/neutron-server restart

shows this information:

Plugin not recognized: please edit /etc/init.d/neutron-server to select the correct .ini file to load for your plugin

In line 17 of /etc/init.d/neutron-server I edit like that:

NEUTRON_PLUGIN_CONFIG="/etc/neutron/plugins/ml2/ml2_conf.ini"

But I still get this "Plugin not recognized"

In this startup-script I have found this:

if [ -z "${NEUTRON_PLUGIN_CONFIG}" ] ; then
        echo "Plugin not recognized: please edit /etc/init.d/neutron-server to select the correct .ini file to load for your plugin"
else
        DAEMON_ARGS="${DAEMON_ARGS} --config-file=${NEUTRON_PLUGIN_CONFIG}"
        DESC="${DESC} with ${NEUTRON_PLUGIN_NAME} plugin"
fi

And directly before that part I added:

NEUTRON_PLUGIN_CONFIG="/etc/neutron/plugins/ml2/ml2_conf.ini"

I restarted neutron-server again. Than I could finally launch an instance:

root@controller:/etc/neutron# openstack server list

+--------------------------------------+-------------------+--------+----------------------+

| ID | Name | Status | Networks |

+--------------------------------------+-------------------+--------+----------------------+

| 99a901d6-692e-442d-ad47-c6a0714a2431 | provider-instance | ACTIVE | provider=10.0.10.250 |

+--------------------------------------+-------------------+--------+----------------------+

YEAHHH!!!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-09-15 08:56:12 -0600

Seen: 476 times

Last updated: Sep 16 '16