Ask Your Question
0

Openstack nova - telnet: Unable to connect to remote host: Connection refused

asked 2016-09-10 04:41:20 -0500

Mary gravatar image

I want to enable telnet port on my virtual machines. I used the command

nova secgroup-add-rule default icmp -1 -1 0.0.0.0/0

to enable ping. And with the command

nova secgroup-list-rules default

I can see the table with enabled port (80 and 22).

On my virtual machine if I use the command

telnet localhost

or

telnet ip_value num_port

I always have the message "telnet: Unable to connect to remote host: Connection refused"

How can I enable this connection?

edit retag flag offensive close merge delete

Comments

By default telnet wants port 23. If daemon telnetd is up, then open port 23 and update security group 80,22,23 ( having 23 available as well ) which belongs your VM

dbaxps gravatar imagedbaxps ( 2016-09-12 12:20:29 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-09-12 23:09:37 -0500

tahder gravatar image

I think it depends on the network you have created.

To telnet with it you need to use

ip netns

from your network namespace you can now execute with it,for example

ip netns exec qdhcp-064b939e-dfbf-4aba-becf-41a83d67f37e ifconfig

unless if you're using floating IP which you can directly access with it (correct me if I'm wrong)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-09-10 04:41:20 -0500

Seen: 599 times

Last updated: Sep 12 '16