openstack neutron client always want to use public endpoint

asked 2016-09-09 08:39:24 -0500

updated 2016-09-14 08:49:04 -0500

I'm trying to use internal endpoint with openstack client, and to do this I put on my keystonerc OS_INTERFACE=internal variable, and most of commands works fine, except when I use neutron commands who always want to use public endpoint, for example commands that are using internal endpoint, and are working fine:

$ openstack  server list
$ openstack  image list

instead neutron commands always try to use public endpoint instead of the internal:

$ openstack network list

It's possible to force neutron client to use the internal endpoint?

edit retag flag offensive close merge delete