Ask Your Question
0

How to add correct admin endpoint for neutron [closed]

asked 2016-09-09 03:01:40 -0500

Matt303 gravatar image

updated 2016-09-14 09:03:29 -0500

Hello

for evaluating openstack I have followed the Debian-Installation with jessie-backports Repository (several times):

http://docs.openstack.org/draft/install-guide-debian/ (http://docs.openstack.org/draft/insta...)

But I failed to set up neutron correctly:

Verifying operations with "neutron ext-list --debug" gives me following input:

DEBUG: keystoneauth.identity.v3.base Making authentication request to http://controller:35357/v3/auth/tokens
DEBUG: keystoneauth.session REQ: curl -g -i -X GET http://controller:9696/v2.0/extensions.json -H "User-Agent: python-neutronclient" -H "Accept: application/json" -H "X-Auth-Token:  {SHA1}1c0715c6801194e915870128b738d7bca850e5d7"
DEBUG: keystoneauth.session RESP: [500] Date: Fri, 09 Sep 2016 07:44:13 GMT Connection: keep-alive Content-Type: application/json; charset=UTF-8 Content-Length: 186 X-Openstack-Request-Id: req-c3d4c2da-d1e5-46cd-9edf-fbf32f49b827 
 RESP BODY: {"message": "The server has either erred or is incapable of performing the requested operation.<br /><br />\n\n\n", "code": "500 Internal Server Error", "title": "Internal Server Error"}

/var/log/syslog gives me following output, while executing "neutron ext-list":

Sep  9 07:58:25 controller neutron-server[3107]: 2016-09-09 07:58:25.455 3290 ERROR oslo_middleware.catch_errors EndpointNotFound: admin endpoint for identity service in regionOne region not found

So I think I need to add the admin endpoint:

All admin related endpoints I listed with "openstack endpoint list":

+----------------------------------+-----------+--------------+--------------+---------+-----------+
| ID                               | Region    | Service Name | Service Type | Enabled | Interface | URL                                       |
+----------------------------------+-----------+--------------+--------------+---------+-----------+
| 33ea6b67f0a14bfc89a08dac10dff163 | RegionOne | neutron      | network      | True    | admin     | http://controller:9696                    |
| 9ac5484cec4b466eb774caa952583940 | RegionOne | keystone     | identity     | True    | admin     | http://controller:35357/v3                |
| a81a2ccd21f34972bb9a41ff62c6dc1b | RegionOne | glance       | image        | True    | admin     | http://controller:9292                    |
| d0bef9c7d223426994ae8bc62df7e8b2 | RegionOne | nova         | compute      | True    | admin     | http://controller:8774/v2.1/%(tenant_id)s |

At the moment, I don't have any ideas to solve this issue. Any help is welcome.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Matt303
close date 2016-09-13 01:47:45.559992

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-09-13 01:47:20 -0500

Matt303 gravatar image

Now I am answering my own question. I have missed a listening port on 9696. I had add the "bind_port = 9696" statement in the default-Section [default] of /etc/neutron/neutron.conf on the controller and compute node and now verify operation with "neutron agent-list".

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-09-09 03:01:40 -0500

Seen: 462 times

Last updated: Sep 13 '16