Ask Your Question
0

how to install glance for mitaka

asked 2016-09-07 21:11:32 -0500

genie gravatar image

updated 2016-09-07 21:13:23 -0500

http://docs.openstack.org/mitaka/inst...

when run second step and third, no this file and command

root@Mitaka-lab:~# . admin-openrc
bash: admin-openrc: No such file or directory
root@Mitaka-lab:~#


 root@Mitaka-lab:~# openstack user create --domain default --password-prompt glance
The program 'openstack' can be found in the following packages:
 * python-openstackclient
 * python3-openstackclient

then i find python3 is default version of python in mitaka, but my downloaded and installed version of ubuntu use python 2.7

http://releases.ubuntu.com/16.04/ubun... in

Server install image

The server install image allows you to install Ubuntu permanently on a computer for use as a server. It will not install a graphical user interface.

There are two images available, each for a different type of computer:

64-bit PC (AMD64) server install image
Choose this to take full advantage of computers based on the AMD64 or EM64T architecture (e.g., Athlon64, Opteron, EM64T Xeon, Core 2). If you have a non-64-bit processor made by AMD, or if you need full support for 32-bit code, use the i386 images instead. Choose this if you are at all unsure.

in

http://releases.ubuntu.com/16.04/

root@Mitaka-lab:~# apt-get install python3.4 python3.4-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting 'libpython3.4-minimal' for regex 'python3.4'
E: Unable to locate package python3.4-dev
E: Couldn't find any package by glob 'python3.4-dev'
E: Couldn't find any package by regex 'python3.4-dev'
root@Mitaka-lab:~# python --version
Python 2.7.12
root@Mitaka-lab:~# lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 16.04.1 LTS
Release: 16.04
Codename: xenial
root@Mitaka-lab:~# which python
/usr/bin/python
root@Mitaka-lab:~#

https://drive.google.com/file/d/0Bxs_...

i had already installed keystone, if change to install python3, is it so late ?

will it have problem if continue installing openstack mitaka with python 2.7?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-09-08 04:24:03 -0500

Tamil gravatar image

updated 2016-09-08 04:24:43 -0500

You can proceed with python 2.7. You are getting No such file or directory, bcoz the admin-openrc not available in that path where you executing. once you have installed the keystone successfully, kindly check this link : [http://docs.openstack.org/mitaka/inst...] to create admin-openrc file
and then continue glance installation.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2016-09-07 21:11:32 -0500

Seen: 354 times

Last updated: Sep 08 '16