glance image stuck in save [mitaka] [closed]

asked 2016-09-07 11:26:50 -0600

updated 2016-09-08 00:59:31 -0600

ANSWER- change record state to killed and this didn't seem to hurt glance at all. I would recommend using command line glance-image upload from command line instead of horizon UI as it seems to have unstable behavior with large images due to timeouts.....

attempting to upload large image (300gb) and was expecting to run into timeout, image is stuck in perpetual save and cant be deleted......

rolled service....

is it alright to just go into the db and remove the record and try again ?

glance api config:

[root@platform2 glance]# cat glance-api.conf | grep -v '^$\|#'
[DEFAULT]
show_image_direct_url = False
bind_host = 0.0.0.0
bind_port = 9292
workers = 24
http_keepalive = true
client_socket_timeout = 900
backlog = 4096
tcp_keepidle = 600
image_cache_dir = /var/lib/glance/image-cache
registry_host = 0.0.0.0
registry_port = 9191
registry_client_protocol = http
debug = true
verbose = True
log_file = /var/log/glance/api.log
log_dir = /var/log/glance
use_syslog = False
syslog_log_facility = LOG_USER
use_stderr = True
notification_driver=messaging
[cors]
[cors.subdomain]
[database]
connection = mysql+pymysql://glance:(*********)@10.1.13.251/glance
[glance_store]
stores = file,http,swift
default_store = file
filesystem_store_datadir = /var/lib/glance/images/
os_region_name=RegionOne
[image_format]
[keystone_authtoken]
auth_uri = http://10.1.13.251:5000/v2.0
identity_uri=http://10.1.13.251:35357
admin_password=(*********)
admin_tenant_name=services
admin_user=glance
[matchmaker_redis]
[oslo_concurrency]
[oslo_messaging_amqp]
[oslo_messaging_notifications]
[oslo_messaging_rabbit]
amqp_durable_queues = False
rabbit_host = 10.1.13.251
rabbit_port = 5672
rabbit_hosts = 10.1.13.251:5672
rabbit_use_ssl = False
rabbit_userid = guest
rabbit_password = guest
rabbit_virtual_host = /
rabbit_ha_queues = False
heartbeat_timeout_threshold = 0
heartbeat_rate = 2
rabbit_notification_exchange=glance
rabbit_notification_topic=notifications
[oslo_policy]
[paste_deploy]
flavor = keystone
[profiler]
[store_type_location_strategy]
[task]
[taskflow_executor]
[root@platform2 glance]#

glance-registry.conf

[root@platform2 glance]# cat glance-registry.conf | grep -v '^$\|#'
[DEFAULT]
bind_host = 0.0.0.0
bind_port = 9191
workers = 24
debug = true
verbose = True
log_file = /var/log/glance/registry.log
log_dir = /var/log/glance
use_syslog = False
syslog_log_facility = LOG_USER
use_stderr = True
[database]
connection = mysql+pymysql://glance:(*********)@10.1.13.251/glance
[glance_store]
[keystone_authtoken]
auth_uri = http://10.1.13.251:5000/v2.0
admin_password=(********)
identity_uri=http://10.1.13.251:35357
admin_tenant_name=services
admin_user=glance
[matchmaker_redis]
[oslo_messaging_amqp]
[oslo_messaging_notifications]
[oslo_messaging_rabbit]
[oslo_policy]
[paste_deploy]
flavor = keystone
[profiler]
[root@platform2 glance]#
edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by bcollins
close date 2016-09-08 00:56:07.420627