Ask Your Question
0

Cannot install openstack-devstack due to MySql-Mariadb conflicts?

asked 2016-09-07 06:08:34 -0500

Ahmed.Syed gravatar image

updated 2016-09-07 08:24:39 -0500

We were trying to install openstack-devstack on Redhat Linux 7. When I executed the below command

      [stack@xyz123 devstack]$ ./stack.sh

During installation we were getting the below error.

      Removing mariadb-libs.x86_64. 1:5.5.47.1.el7_2 - u due to obsoletes from installed mysql-community-libs-5.7.12-1.el7/x86_64
      Restarting dependency Resolution with new changes
      Running transaction check
      Package mariadb-libs.x86_64. 1:5.5.47.1.el7_2 will be installed
      Processing Dependency : mariadb-libs = 1.5.5.47-1.el7_2 for package: 1: mariadb-devel-5.5.47-1
      Finished dependency resolution
      Error : Package : 1: maria-db-devel-5.5.47-1/el7_2
         Requires: mariadb-libs(x86-64)= 1:5.5.47-1.el7_2
         Available: 1:mariadb-libs-5.5.35-3.el7.x86_64
                mariadb-libs(x86-64) =1:5.5.35-3.el7
      You could try using --skip-broken to work around the problem
      You could try running: rpm -VA --nofiles --nodigest

Note: MySQL is already installed on my machine. And I cannot remove MySQL as it is being used by some other users.

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2016-09-19 09:47:37 -0500

packstack --gen-answer-file=my-answer-file.txt

Answer file will look like this (excerpt only!! file is really long):

# Path to a public key to install on servers. If a usable key has not
# been installed on the remote servers, the user is prompted for a
# password and this key is installed so the password will not be
# required again.
CONFIG_SSH_KEY=/root/.ssh/id_rsa.pub

# Default password to be used everywhere (overridden by passwords set
# for individual services or users).
CONFIG_DEFAULT_PASSWORD=abc123

# The amount of service workers/threads to use for each service.
# Useful to tweak when you have memory constraints. Defaults to the
# amount of cores on the system.
CONFIG_SERVICE_WORKERS=%{::processorcount}

# Specify 'y' to install MariaDB. ['y', 'n']
CONFIG_MARIADB_INSTALL=y

Once you change this to no (if you run packstack you can do interactive as well), you can run your packstack answer file and it will only attempt to login to db and create dbs for services....

edit flag offensive delete link more
0

answered 2016-09-18 23:25:03 -0500

Ahmed.Syed gravatar image

updated 2016-09-18 23:27:14 -0500

Unfortunately removing MYSQL solved my issue.

   yum remove mysql-community-server.x86_64 mysql-community-client.x86_64 mysql-community-common.x86_64 mysql-community-libs.x86_64 mysql-community-libs-compat.x86_64 mysql57-community-release.noarch
edit flag offensive delete link more

Comments

you could generate a packstack answer file as well and tell it to not install db...

bcollins gravatar imagebcollins ( 2016-09-19 01:09:20 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-09-07 06:08:34 -0500

Seen: 504 times

Last updated: Sep 19 '16